The page editor/rendering is not resizing

Bug report

The page editor/rendering is not resizing.

Troubleshooting steps taken

  • restart inkdrop
  • quit inkdrop
  • brew rm inkdrop
  • rm -rf ~/Library/Application\ Support/inkdrop
  • brew install inkdrop
  • disconnect macbook from external displays and repeat steps listed above

Console output

Macbook model information

Other details

I have never encountered this issue on other macbooks which are newer models. This macbook is unable to support 2 external displays without a pluggable USB-C hub and DisplayLink installed.

I use Ansible to set up my Macbook, which includes installing and configuring Inkdrop. You can review the automated steps here


  • Device: Macbook Pro 13-inch, M1, 2020

  • Platform: MacOS

  • Platform version: Sonoma/v14.4.1

  • App Version: 5.8.0

How to reproduce the issue

Run Ansible playbook to install and configure inkdrop

mkdir ~/temp/
git clone ~/temp/macbook-config
cd ~/temp/macbook-config
ansible-playbook ./restore.yaml --tags inkdrop

Launch inkdrop

I am able to recreate the issue with no errors in the console.

I am also facing the same problem.
It seems that this behavior started with version 5.8.0.
I am using the Windows version.

so with “editor is not resizing” you are referring to the red marked areas? (see the attached image below)

or am I misunderstanding you?

This is a new feature that was added in v5.8.0.
For more information and how to disable this behavior, see the announcement of v5.8.0

Also there are a few other post regarding this:

It’s a feature, not a bug! … Thank you, Lukas.

1 Like

Sorry for the confusion guys :innocent:

The ‘Readable line length’ option has been disabled by default as of v5.8.1.
Please check out here for more details:

Thanks again for the feedback!