Let's Encrypt root certificate expiration error

Bug report

Starting today, Inkdrop began showing as “offline” in the bottom left corner. Choosing quick or full sync did not change this, and neither did relaunching the app. I ensured I have the latest updates to macOS and Inkdrop.

I logged out and attempted to log back in, but the login page shows an error.

Error message:
certificate has expired Please check your system configuration or report the problem.
Status code:

Info

  • Platform: macOS
  • Platform version: Big Sur 11.6 (20G165)
  • App Version: 5.4.2

Reproduce

Run the program on macOS

iOS does not seem to be affected.

Speculation

Possibly related to Let’s Encrypt previous root cert expiration which is today? https://letsencrypt.org/docs/dst-root-ca-x3-expiration-september-2021/

1 Like

Here’s a screenshot of the error message I get when I try to log in.

I am getting the same message on 5.4.2 on Unbuntu 20.04.3

Me too, exactly the same. I’m on a Mac (10.15.7, Catalina). This is my first login on a new account. Can’t get into the app.

I am able to log into the Android mobile app version 4.2.0 on Android 10.

I’m looking into it now.

Yeah, looks like so.

Me too, I’m on Windows 10.

Found an issue on Electron:

Workaround just for now:

Ignore the cert error by adding the following config in your config.cson:

"*":
  core:
    network:
      strict_ssl: 0

Looks like it’s been fixed in Electron:

I’ll try the fix.

UPDATE: It works! I’ll publish the fixed version soon.

Thanks for your patience.
Okay, I built fixed binaries here. Can you guys please try them?:

Please don’t forget to remove the workaround config mentioned above: strict_ssl: 0.

1 Like

Worked on my macOS (x64).

1 Like

@Yohsuke_Murase Nice! Thanks for letting me know.

1 Like

Fixed on my Windows 10 machine.

It worked on my windows 10 pro machine at v.5.4.3 !
Thank you.

Awesome. Thank you, @Peilun_Ma and @Yuki_Matsuda!
Looks like it’s working fine. I’ll publish it soon.

1 Like

v5.4.3 is out!:tada: Thank you for your reports!

  • NOTE: Auto update must be not working due to the issue, so please download manually from here:

https://my.inkdrop.app/download

2 Likes

All good on Linux too! Thanks @craftzdog :clap:

1 Like