Thinner scrollbar on Windows and Linux


(Leptospira489) #1

Bug report

image

It is part of the Version 4 Beta I believe

Info

  • Platform: Windows

Reproduce

Just change the size of the very left sidebar until it is right before it hits the longest named notebook.


And another thing:
image
That black bar is a bit too large, ugly, and it clashes with the highlighted page. Maybe make it thinner and a lighter instead of darker color.


(Takuya Matsuyama) #2

Hi leptospira489,

Thank you for the suggestion.
Yeah, the scrollbar on Windows and Linux seems like kind of big. I don’t like that, too.
Let me consider how to solve it.


(Takuya Matsuyama) #3

4.0.0-beta.6 has thinner scrollbars.
Thanks for the suggestion!


(Leptospira489) #4

you are welcome! You still should fix the odd thing with the note number being anchored to the left:
image


(Takuya Matsuyama) #5

I don’t see the note number badges left-aligned. The right margin you pointed out is scrollbar.


(Leptospira489) #6

No, half of it is the scroll bar, the other half is padding for the number of notes. Unless there isn’t padding at all, if thats the case, could you add some pixels of padding so the number can’t be that close to the name of the notebook?


(Takuya Matsuyama) #7

That makes sense. The count badge has 4px right margin but no left one.
Sure, I’ll add it!


(Takuya Matsuyama) #8

Fixed it in 4.0.0-beta.7. Thanks!


(Gustavo Trott) #9

It’s a little bit ugly in macos as well!
43

I have this problem in my web systems… then I solved using plugin https://github.com/mdbootstrap/perfect-scrollbar

I also saw really good job in the plugin https://github.com/gromo/jquery.scrollbar/
maybe if you find something similar would be much better look!


(Takuya Matsuyama) #10

Hi Gustavo,

macOS does not show scrollbar except for when scrolling by default.
I guess you disabled it?


(Gustavo Trott) #11

Interesting, I never knew about this option!
For me it was selected “Automatically based on mouse or trackpad”, then the scroll is being shown when I have several folders in the sidebar.
Maybe It happens because I don’t use a Magic Trackpad or Macbook trackpads.
But if the default option is: “When scrolling”, so probally this is not a problem for almost macOs users.
Thanks


(Takuya Matsuyama) #12

Yeah, that’s exactly I mentioned.
it makes sense that’s due to other vendor’s mouse.
Thanks for letting me know!