Impossible to connect live-export

Hello Mr. Takuya, after seeing your tuto on how to implement a blog using Astro and Nexjs i went ahead and decided to make my own starting just with Nextjs without using Astro. Everything works fine but as soon as i try to connect live-export i encounter and error. I looked at the instructions on the readme and i really don’t understand anythind about the error i’m encountering.

Can you show me the errors?

Hello, Takuya San. I’m also having trouble connecting my notes to the repo “uses” I forked from you. I’m using Astro. I made a .env file and updated the credentials with my own, but I’m encountering an error when I run this command. Any help will be appreciated, thanks

What do you get when running the following command?

curl -v http://<USERNAME>:<PASSWORD>@localhost:<PORT>/

Have you properly specified your book ID? GitHub - inkdropapp/inkdrop-live-export: A library for programmatically exporting notes to local filesystem from Inkdrop

I replaced the ‘@’ symbol in my username with ‘%40,’ which allowed me to continue to connect

Have you tried escaping ‘@’ in the INKDROP_USERNAME in the dotfile?

Or, can you try not using the email address as the username for the local server?

Also, you can enable debug logs:

A post was split to a new topic: The UI gets corrupt when uninstall the current theme

I encountered the following error while attempting to run the command: ipm-beta install dev-tools

I have tried escaping ‘@’ in the .env file, or any further modification of changing a username will answer: invalid credentials.

I apologize, but I have never attempted debugging before. Is this the correct approach?

Ahh thanks. Currently, installing plugins via the ipm command is discouraged. It will be removed in the future. Can you try installing dev-tools via the preferences?

Yes, it will output logs when you invoke the API so you can see what’s happening.
Also, I want you to add the following DEBUG env variable in your .env file:


With this flag, live-export will output detailed logs.

I tried it myself and got it to reproduce!

  app:error TypeError: Cannot read properties of undefined (reading 'getLocalDB')

Looks like a bug in the beta version. Will fix it!

Gotcha. Can you please try this patch?

1 Like

Omg, I might have just connected to it; I still can’t believe it after numerous times; it’s something happening. Before nothing has broken, and before I get too excited, I will test a bit more in the next couple of days and will update you later on how I am doing. So far, thank you so much for all your support here. I want to point out that I’ve noticed some conflicting notes or duplicates being displayed, but I will investigate this further tomorrow.

CleanShot 2023-10-05 at 1 .33.11

1 Like

Congrats, and I’m glad it works!
please enjoy and let me know if you find any issues.

1 Like

The issues reported in this topic have been resolved in beta 3! Thanks again for the report.

1 Like