Importing files bug on Windows

Bug report

Importing feature on latest version 5.4.3 is bugged. The app does not show any files in file explorer when trying to import markdown files. It shows window of selecting a folder, not a file. Even when a folder made up of md files is selected, it shows “importing Markdown files completed” but really doesn’t import anything. When importing HTML files, some plugin-based syntax, like mermaid and math, disappear.


  • Platform: Windows
  • Platform version: Windows 10 Home
  • App Version: 5.4.3

How to reproduce

When attempting to import by selecting the folder

When attempting to import by selecting files

(both approaches give same result)

( should have been added)

Hi Wakate,

Thanks for the report. That’s weird.
Is the extension of your Markdown files .md?
Is it possible to share what’s actually in the filder “md files”?
When selecting “(Root)” on the “Import Notes from Markdown” dialog, you can only select a folder.
If you selected a notebook, you can select .md files.

Importing Marmaid and Math from HTML is not supported.


Thank you for the info regarding importing Mermaid and Math. As for importing md files, I attempted it again. I selected (Root) and selected a folder, but nothing was imported. I tried the other way and selected a notebook but it still gave me the option to select a folder. Here is a short vid I recorded.

As for the markdown file, its extension is indeed .md and vscode can recognize it. The file’s content is this:

# test note

# test note

# Something

graph LR
    A --- B
    B-->C[fa:fa-ban forbidden]
2(x+5)-7 = 3(x-2)

T^{i_1 i_2 \dots i_p}{j_1 j_2 \dots j_q} = T(x^{i_1},\dots,x^{i_p},e{j_1},\dots,e_{j_q})
$x = y$

    participant Alice
    participant Bob
    Alice->>John: Hello John, how are you?
    loop Healthcheck
        John->>John: Fight against hypochondria
    Note right of John: Rational thoughts <br/>prevail!
    John-->>Alice: Great!
    John->>Bob: How about you?
    Bob-->>John: Jolly good!

Thanks for the information.
BTW, v5.4.3 is not the latest version. Can you please try v5.5.0? It is built with the newer version of Electron, so it maybe works well.

Apologies for the misinformation. I am indeed using Inkdrop v5.50. I didn’t know where to check the latest app version so I assumed it the latest version mentioned from the release notes.

I tried to check the console for any errors mentioned. I got this:

I am not sure if they are relevant to the bug.

Okay, so you are on the latest version.
I got it to reproduce on my machine.
Looks like it’s a windows-specific issue.
I’ll fix it!

1 Like

Sorry for the delay. I’ve fixed that. Can you please try this patch?

I’ve tried the patch myself and it seem to be working great.

Cool :raised_hands: Thanks @chanakan5591
I’ll roll it out.

1 Like

Not working on Windows 11.

Still can’t import files, I tried with one folder, I’m using latest version.

Takuya didn’t roll it out to all the users just yet. So if you want to check if it works, you can try download the patch link he sent.

Patch not working for me.

v5.5.1 is out🎉

@Yocesi_Yo You have to choose a notebook instead of “(Root)” to import individual Markdown files.