How Disable Auto link title

This feature is make slowly my work, so I don’t need it,
How disable this completely useless feture?

Hi Ryota,

You can bind Cmd-V with the command core:paste-as-plain-text to body.

Alternatively, you can press cmd-shift-alt-v to dispatch core:paste-as-plain-text.


1 Like

Thanks! I’ll try it!

I just released v5.8.1-beta.1, which supports disabling “Paste URL as link” via Preferences. Check out below:


I really appreciate you about that!
To be clear, I prefer that feature and works fine for OSS works.
But in company works, all internal resource are deployed behind basic auth.
So doesn’t work file while company work. :sweat:

1 Like

Hi Takuya,

Trying to enable (put a check mark) “Paste URL as link” from a version of 5.8.1-beta.1 is not to bring back a dialog to choose a auto-link title.

My current workaround is to add cmd-v to keymap.json

    "body .native-key-bindings": {
        "cmd-v": "native!"

Thank you,

@Ryota_Murakami Oh, I haven’t ever imagined that it would cause such trouble in the office network. Glad it solved.

@Bundit_Jianpinitnan That looks strange, since I can’t reproduce it. I suspect that you have another keybinding for cmd-v somewhere?

It could simulate this issue by switching to use other syntax themes.

@Bundit_Jianpinitnan core:paste is the default command for Cmd-V.
Can you try running the following snippet in the Developer Console to check the bound commands?

inkdrop.keymaps.findKeyBindings({keystrokes: 'cmd-v'})

In my case, the output looks like:

Syntax themes have nothing to do with pasting behavior. Can you check the config.json?

  "*": {
    "editor": {
      "pasteUrlAsLink": false,

You can remove the above line to revert it to the default.
If the value doesn’t exist, the feature is correctly enabled as it’s enabled by default.

Hope it helps.

Hi Takuya,

It has been my fault to copy a link from the note-taking app itself rather than the web browser URL.

Thanks so much for your support.

1 Like

Thanks, that is also helpful to me!

1 Like

It’s been resolved in v5.8.1.
Thanks again for the feedback!