FTS prefix queries not working

macOS Ventura 13.6
Inkdrop Version 5.6.0 (5.6.0) Apple Silicon

Search does crazy things:

  • selected “all notes” finds less notes than in a sub/sub-notebook
  • typing 3 letters find one note, adding a fourth letter finds 10 notes


  • Deleted app (by deleting app bundle from /Applications).
  • rescnched from scratch

Did not try:

  • X86 version on M1

No issues on my old MacMini and iPhone and iPad

Hi Thomas,

Thanks for the report. That’s weird.
It might sound like an FTS index issue.
Can you please try Developer → Rebuild FTS Index? It takes a while.
If it still doesn’t work, you could try removing the local database and sync it again by the following steps:

  1. Quit the app
  2. Open ~/Library/Application Support/inkdrop/
  3. Move the local database with the following command:
    • mv db db.bak
  4. Launch the app and let it sync again

Depending on the query, it may work as you said because of Porter stemming algorithm . Here is the detail:

Hope that helps.

Thomas’ reply via email (Please post a comment instead of replying to the notification email):

Thank you Takuya!

I tried both, but both did not change anything.
I deleted and reinstalled the app yesterday (but the DB was still there)

I attach 3 (new) screenshots to illustrate what I described.

  1. All notes „cer"

  1. All notes „cert"

  1. Just Subnotebook “cert“ - these didn’t show up in all notes search.

ahhhhhhhhhhh I found that the prefix modifier is not enabled in the latest version!!!
I will enable it back in the next release.
Thanks for letting me know!

1 Like

Could you try this patch?


Hope it works!


Thank you.


Did the patch resolve your issue?

Thank you. Yes, a 1 minute test did show no more strange behavior!

BR, Thomas

1 Like

Awesome! Thanks for checking it. I’ll prepare rolling it out officially soon

v5.6.2 has been released :partying_face: Thanks again for reporting.