Unable to upload photo on iOS

Bug report

I cannot upload a photo from the library or a taken photo in Inkdrop. After I do the app becomes completely unresponsive and I have to close the app to continue using it. I have tried uninstalling and reinstalling the app.

Info

  • Platform: iOS
  • Platform version: 14.4.1
  • App Version: 4.1.0

Reproduce

1 Like

Hi Ryan,

Thank you for the report.
That’s weird. I tried to reproduce it on my iPhone 11 Pro and iPod touch (7th gen) but it works fine.
It could be a device-dependent issue but I’m not sure why at the moment.

1 Like

This is an iPhone SE (2020).

It could be react-native-image-picker’s issue but I couldn’t find any related issues.
Let me know if you find anything.

This?

No, I guess that’s not a bug.

I think it is related to these new photo permissions:

Other apps prompted me about them but Inkdrop never does.

That’s the permission to import the existing photos.
As you can launch the camera, you should have sufficient permission like so:

Oh, but Instagram has “Photos” permission:

Interesting. I’ll look into it.

1 Like

@phi_sch also reported the same issue.
Interestingly, his phone is also iPhone SE.
I’ll try to reproduce it on an iPhone SE simulator.

1 Like

Couldn’t reproduce it on the iPhone SE simulator.
UIImagePickerController basically doesn’t require permission to import images, as you could already select an image / take a photo.
I also tried to reinstall the app but it successfully inserted an image on my iPhone 11 Pro (iOS 14.4.1 - latest).
It’s mysterious.

I encountered similar issues on iOS14 with an app I develop for a client related to the new PHPickerController. I look into it and may share what was problem there and how we fixed it.

My iOS Settings for Inkdrop look like this ->

Although the camera option appears, I can take one, but it wont appear in the note and from that moment on, the app just get stuck in this node and the editing mode and I have to kill and restart the app.

For other apps there appear also the Photos Icon and options. For Photos I’d choose “selected images” in those apps.

2 Likes

I wonder if these are some kind of inherited ‘ghost’ permissions. I think my phone has never had an iOS earlier than 14.x.

Is there a way to explicitly add/ask for ‘Photos’ permission?

since the introduction of iOS14 and its new privacy options, apple recommends to use the PHPickerController and let users select the single images the app can access. Thereby there is no need for the app to ask for any permissions https://developer.apple.com/videos/play/wwdc2020/10652/

But it seems to have some bugs or at least some pitfalls for developers implementing it.

Thanks for the info.
Maybe I need to tweak react-native-image-picker to use PHPickerController.

2 Likes

I’m interested how it will work out for you. In my company we encountered similar problems with Flutter. Maybe your experience with this iOS-API is helpful.

anyway, I would recommend watching the two WWDC sessions on this topic. Maybe you can solve it another way.

1 Like

Well, I changed the following code for the image picker to always ask for photos permissions:

I’ll let you know when published it on TestFlight.

1 Like

Published it on TestFlight. Could you try it? @phi_sch @Ryan_McQuen

1 Like

Hi, thank you for the TestFlight link!
So, that’s super weird.
The Problem stays the same: I can not add an image from my photo library (even if I picked one or granted every permission) nor can add one from the camera app.
But after I added an image from my computer in the same note and only thereafter I was able to add images in that particular note and the entire iOS app. Since then, I can add as much images and photos in any old or new note inside the App (the TestFlight Version).

I reinstalled the version from the AppStore and it now works. I really don’t know what did cause the initial problem. The app now don’t has any permissions, except for the camera app and the selected images