Sync not working on Android

I am using Inkdrop for a few years now but I encountered a sync issue on my android smartphones

Bug report

Notes and notebook are not downloaded / synchronized on my Android devices.
When I install the Indkrop app on my Android devices, only some very old notes are downloaded and no notebook.
On different PC (Windows and linux), synchronization is ok in both directions.


  • reproduced on :
    • Google Pïxel 3 and Google Pixel 5
    • Samsung Galaxy TAb A 2018
  • App Version: 4.1.0 (67)
  • using the official Inkdrop DB (not a local or custom Couch DB)


  1. I already have an Inkdrop account that I can sync between different computer (Windows and linux)
  2. install Inkdrop on Android device
  3. enter login / pwd for the existing account
  4. only some old notes are synchronized on the Android devices, and no notebook appear
  5. deleting local DB and re-sync does not solve the pb

NB : I have tried to create notebook on the android device, the notebook seem to be created locally but does not appear on the other devices

note : synchronization process seems very short on Android compared to a full sync on PC. I would suspect that either a timer or a bug is stopping the synchronisation process at some point, preventing all recent activities to be sync.

Hi Bertrand,

Thank you for the detailed report.
Some quotes from your email:

  • I am not using custom Couch DB, I am using your Inkdrop servers (regular usage)
  • I have tried to delete the local DB, but no improvement
  • I have reproduced the issue on a android tab with e fresh install

I tried to reproduce it on my Android device (Essential Phone with Android 10, and Google Pixel 5 with Android 11) but they worked fine. I have more than 1,000 notes in my account.
So, I don’t understand what’s going wrong at the moment.

Maybe you have the same problem as @Ben_Samuel.
He found a workaround that downgrading v4.0.4 works.

Could you check that thread and try it?

I also found that the current beta build (v4.1.1 (68)) works for me.

I guess it has nothing to do with this issue but it might work on your device.

Hi i just tried the beta version but the behaviour is the same : blocked on syncing at 123 on 870 notes.
I agree that I probably have the same issue like @Ben_Samuel , i ll try version 4.0.4 as workaround.

Thx for your reply and enjoy paternity :grinning:

Hello Takuya,
The workaround proposed by @Ben_Samuel is working : installing v 4.0.4 works fine for me
So I’ll use this version and wait for the final analysis et root cause correction to upgrade

1 Like

FWIW, I upgraded to 4.1 after the initial sync went through and syncing still works fine.

Thank you for letting me know, @Bertrand_Bascary.
I guess that’s due to the fast native implementation of E2EE introduced in v4.1.0.
I suspect that a particular note has an issue like decryption failure because Bertrand only gets 123 notes, and Ben has the issue with the initial sync on v4.1.0.
I’ll look into it after the break.