Initial sync problem with android 4.1.0

Bug report

I was installing inkdrop on a new Android phone. After logging in, sync would start, it would spin, but no notes would download.

Tried deleting the local DB and resyncing from Advanced, no luck.

Tried uninstalling and reinstalling, no luck.


My workaround is to downgrade to 4.0.4 for initial sync.

  • uninstall Inkdrop
  • install 4.0.4 using an APK site ( in this case, but I can’t endorse them)
  • go to Play store and update to 4.1.0


  • Platform: Android 11
  • Model: Samsung Galaxy S20 5G
  • App Version: 4.1.0


Install Inkdrop from the Play store on a new Android phone.

Log into your existing Inkdrop account.

Expected: notes start downloading promptly.

Observed: the sync spinner appears, no notes download

1 Like

(Mostly wanted to post this for the workaround, as it means there’s no need to drop everything and fix it. Enjoy your leave and take care of your kid.)

Hi Ben,

Thank you for reporting it.
Not syncing on your new Android phone - that’s weird.
I tried to reproduce it on my Essential phone (Android 10) but it worked fine.
However, my Android phone is kind of old now.
I decided to buy Google Pixel 5.
I’ll test on it.

Hi @Ben_Samuel and @Bertrand_Bascary,

Thank you for being patient. Now I’m back to work.
I’ve got a Google Pixel 5 (Android 11) and tried to reproduce the issue but couldn’t.
So, I suspect that it may be an account-dependent issue.
To make sure that, I’d like to know if the initial sync works with a test account.
Could you try logging in with this account from your phone?

If you got the same issue, it would be due to another reason.

Wait, I think I found a bug. I will push a beta build via TestFlight

It may take me a day or two before I can get to it, but I’ll try reinstalling from scratch, make sure I can reproduce the bug with the prod version, and then try the beta build.

Thanks, Ben!

Hello Takuya, i have tried that on the Google Pixel 3 that caused problem for me before, and it seems to work fine. At least this is what I get

Hi Bertrand,

Thanks for trying it!
So, it looks like the issue depends on the user database, not on the device.

I just pushed build 69 (4.1.1) on the open beta channel, which is in review now.
I’ll let you know when it got passed.

Okay, it’s published! Could you try the beta build here?
I hope it works.

Okay, I’m testing on a Pixel 4a. I reproduced the bug with version 4.1.0, testing the beta…

I had 4.1.0 installed, and it was exhibiting the Sync / spin / Sync / spin behavior.

I updated to the beta (version reports 4.1.1 build 69) and opened it. It tried to sync, and then simply stopped. No notes or categories downloaded to the device.

Paused the app, it again tried to sync and stopped. Again, no notes or metadata downloaded.

Delete LocalDB and Sync, same symptom.

I don’t usually use this phone for Inkdrop, so it’s not a big deal for me to try something else.

Hi Ben,

Thank you for trying it. Okay, it didn’t solve.
Hmm, this is a cryptic bug.

Since I can’t reproduce it, it is hard to find what actually causes the issue.
There are two options that I can come up with to try.

  1. Reset the Inkdrop database

I suspect that a particular note is blocking the sync for some reason.
Since v4.1.0 works, this should be related to the E2EE.
By resetting the remote Inkdrop database, your desktop client tries to encrypt and send the whole data again.
That might solve the issue, however it will not solve the root bug.

  1. Try to reproduce on my device

If you allow me, could I log in to your account from my device?
I understand you have a lot of private notes, but that’s the only way to reproduce it on my environment at the moment.
I promise I do it only for the debugging purpose and you can change the password once it’s done.
Please DM me your account if it’s okay.

Thanks, Ben. I’ve got it to reproduce on my phone. This is so weird. I’ll look into it deeper.

1 Like

Okay, I found a workaround for this!
I’ll push a beta build soon.

It’s out! @Ben_Samuel @Bertrand_Bascary Could you update the beta build to 70?
It worked on my device.

1 Like

:partying_face: :clap:t2: Downloaded the beta; it worked without a hiccup! :tada:

1 Like

Thank you so much for your cooperation, Ben!

v4.2.0 is out🎉 Thanks again for the feedback XD
Credited you guys:

1 Like