Math plugin not working nor found

Hello there! :slight_smile:

I just recently found out the math official plugin has been removed from the app, since I can’t find it in the ‘install plugins’ section, nor can I render any document if that plugin is active, so I was wondering if it’s a bug or if this plugin will be discontinued from this version onwards.

I have restarted my pc, and also uninstalled the app and reinstalled the newest version. I also tested all the other plugins I have installed separately in case a mix-match was causing the app not to render, I’m running Windows 11 Pro 22H2 and Ubuntu based Zorin OS 16.3. Uploading some screenshots to demonstrate what’s happening.

I can’t find any topic related to this so figured out I would ask about it, if it’s me just not having read something I’d be lovely if you can link me to that

Hi Jaime,

Thanks for the report.
Do you mean that the math plugin cannot be found in your Windows and Ubuntu?
Which version exactly do you use? v5.5.3 or v5.6.0-beta.1?
The plugin is not discontinued.
Can you please check if you get any error in the console logs by selecting the menu: Developer -> Toggle Developer Tools?

Hello, thanks for answering :slight_smile:

I’m using v5.5.3 and the plugin can be found locally in both Ubuntu and Windows, but it can’t be found in Plugins -> Install for installing.

My main problem is that when I try to render something that uses the math plugin, it shows the error on the second image of the main post. These are my console logs.

Those are the Windows console logs, but the same thing is happening in Ubuntu.

  1. can’t be found in Plugins → Install

Ah, I guess that’s because the latest version of the math plugin (v1.3.0) is not compatible with v5.5.3.
I’ve released it recently for v5.6.0-beta.0 and it’s currently being tested for the official release.
It looks like v5.5.3 is ignoring incompatible versions.
Other plugins like Mermaid may be affected as well.

There is no workaround for this issue at the moment. Please wait for the v5.6.0 to be released.

  1. Error: Cannot read properties of null (reading ‘useState’)

I suspect that you have installed React globally somewhere in your PATH.
The plugin unexpectedly loads the wrong React library in your environment.
Can you try uninstalling it with a command like npm uninstall -g react?

Thanks, since I already have the plugin installed I don’t really have any problems with 1., but I just thought that was causing react to act in a funny way, I just happened to found out that for some reason, a package.json file happened to get copied into my $HOME directory, causing inkdrop to have problems, I had already tried npm uninstall, but for some reason that package.json file was interfering with it, I removed it and then ran npm uninstall -g react and now everything works perfectly.

Thanks for the support, love your work and loving inkdrop! :slight_smile:

1 Like

Great, Jamie! Happy it’s been solved :raised_hands:

v5.6.0-beta.1 would fix the global path issue. Thanks again for reporting!