It doesn't fall back to the default themes if a custom one does not exist

Very strange. After I upgraded Inkdrop on my personal MacBook Air, it doesn’t work now.

But it works fine on my work machine which is a MacBook Pro.

Both are M2 chip.
Both are OS X 14.1.2

I tried to uninstall and re-install Inkdrop on my personal machine, but still looks like this.

Please let me know if you have any ideas.

Hi Brenton,

Thanks for reporting.
Looks like one of the plugins you installed causes the app to crash.
In v5.6.0, there are some breaking changes to improve its launch speed.
Some plugins were not updated accordingly even though I’ve asked them.
You may be able to see an error log in the Developer Console from the menu Developer → Toggle Developer Tools and which plugin is causing it.

If it is hard to find the culprit, can you please try uninstalling all the plugins manually?
They are stored in ~/Library/Application Support/inkdrop/packages.
Hope it helps.

Awesome! That helps. Thank you, Takuya.

I tried to manually delete all plugins just to get back to normal.
When that did not make an effect, I just deleted the entire inkdro/packages directory, deleted the application in Applications/ and reinstalled.

It’s weird because it still shows I have all those plugins installed and has the same issue. I can’t see how to delete the plugins from the UI. Is there somewhere else something could be cached? I’m not sure how I can get rid of my plugins.

They are the built-in plugins, which can’t be removed.
That’s weird. Could you share your config.json in ~/Library/Application Support/inkdrop?
Also please show me the errors you get in the developer console: Developer → Toggle Developer Tools.

Thank you. Please let me know if I can provide any other details.

1 Like

Thanks for sharing.
I guess the theme settings are invalid.
Could you fix it like so?

"themes": [

The app should fall back to the default theme if the custom theme doesn’t exist but it doesn’t, which would be a bug.
I’ll fix it!

1 Like

Awesome! That fixed it. And a plus that we uncovered a small bug :japanese_goblin:!

Thank you! I love the editor :heart_on_fire:

1 Like

Great :star_struck:

I had the same issue but I was on a Dell Latitude 5540 Windows 11 23H2 and I had the plugins marterial-dark-mod-syntax and vibrant-dark-ui installed. It caused my window to look like this below. I went into c:\users\user\appdata\roaming\inkdrop

Then find the config file. Open it with Notepad ++ and find the “themes” area. then update to the default themes:


It should be fixed in v5.6.3-beta.0 :raised_hands:
This topic will be resolved in the official release.
Thanks again for reporting, @Brenton_Morris!

1 Like

landed in v5.7.0 :tada: