How to properly rebind keys for inkdrop and vim plugin? Can't get it to work

For Inkdrop and the vim plugin, what is proper way to rebind keys?

When I use vim, I never use esc to get out of insert mode. I normally use another key combination. For Inkdrop, I can’t figure out how to get this to work. I am trying to bind qq to get to normal mode. I have this in my keymap.cson file:

'.CodeMirror.vim-mode:not(.insert-mode):not(.key-buffering) textarea':
    'q q': 'vim-mode:reset-normal-mode'

And I can even see the added key in the Keybindings in the preferences menu.

When I type qq in insert mode, it simply inserts the characters.

I have also tried other keys, such as ctrl-c and alt-c, and have had no luck. I have also tried putting these rules under the ".CodeMirror.vim-mode.normal-mode textarea" rules in tkeymap.cson.


  • Platform: (macOS/Windows/Ubuntu/iOS/Android)
  • Platform version: (Sierra/10/16.04)
  • App Version: (3.9.0)

Hi banj,

Thank you for the question.
You can configure it like so:

'.CodeMirror.vim-mode.insert-mode textarea':
  'q q': 'vim-mode:exit-insert-mode'

You can check the default keymaps for vim here:

It worked, thanks craftzdog!

1 Like

Hi, in standard Vim Ctrl-[ works the same way as Escape. I’ve got this muscle memory as I use a MacBook Pro without a physical escape key. Can this mapping be added to the Vim plugin by default?