Cannot sync from office network

I can sync from my home network but cannot from office network. I use the same Windows 10 laptop computer both in home and office. It may be due to company security to deny URL access to Inkdrop server. This is serious issue for me if there os no choice for it. Sync from company office is the most important factor.

Hi Shinichi,

Thank you for the report.
Please read the following documentation for using Inkdrop behind the corporate web proxy:

And here are some related issues:

Thank you for reply. I tried everything as pet the maual “Working behind web proxy” but cannot sync yet. The problem is still same.
Could you advise any further action to take?

Could you please explain the detail about your issue?

  • What kind of error do you get
  • Your OS environment
  • Your network environment
  • Your current proxy setting

Web proxy is hard to support because it depends on your corporate network and I basically can’t reproduce it.
You have to work with your network system administrator if the proxy setting does not work.

  1. Reply to your queries
  • What kind of error do you get : No specific error message. It looks sync completed but actually not.
  • Your OS environment : Windows 10 Pro.
  • Your network environment : unknown
  • Your current proxy setting : use automatic script
  1. config.cscon
    My config.cscon file is modified as below. Please check if there are anything wrong.
    “aaaaa” is my login id and “xxxxxxx” is my password.

           machineId: "HXT65zBwo"
         devMode: true
           fullscreen: false
           maximized: false
             w: 323
             x: 448
             y: 37
             w: 237
             h: 833
             w: 875
         themes: [
         viewMode: "sideBySide"
         http_proxy: "http://aaaaa:xxxxxxx@webproxy:8080/"
         https_proxy: "http://aaaaa:xxxxxxx@webproxy:8080/"
         strict_ssl: 0
  2. Configuring ipm
    I also run the ipm command by copying and pasting from the Working Behind Web Proxy manual.

  3. Allow Self-signed Certifivates
    Consequently, added “the strict_ssl: 0” in config.cson and run ipm as stated in the manual.

This is all what I did. Appreciate if you can find any other advise.

Your proxy setting seems to be correct.
Since you don’t know about your network, it’s not possible to know what is actually preventing the app from accessing outside of the corporate network.
If you’d wish to investigate further, please try following this topic and let me know the error code:

The error you get with the above code will tell you a reason that you have to work with your network administrator to fix the issue such as his case:

A bug found in the network module (axios) has been fixed in v5.0.1.
I’d expect it solved your issue.