Cannot empty trash

Bug report

Just upgraded to 4.5.2 from 4.5.1, but cannot seem to empty the trash (by right clicking on trash and selecting “Empty trash”). If I right-click on a trashed note and say “Delete permanently” it works.


  • Platform: macOS
  • Platform version: 10.15.3
  • App Version: 4.5.2


Try to empty trash.

Hi Vincent,

Thank you for reporting it.
That’s weird, I could empty trash as expected.
Please check if you got any error in the console log by selecting the menu: Developer -> Toggle Developer Tools.

Interesting. I tried with it now and it worked fine. Not sure why it didn’t work before. Possibly due to me fiddling with couchdb directly (I’m writing an importer to convert Quiver notebooks to Inkdrop).

At any rate, I just tried it and it worked, I don’t see anything in the console either.

I guess it’s related to the Electron’s context menu bug:

I’ll try upgrading it in the future release and let’s see if it solves.

v4.6.0 is built with Electron@7.1.13 which has a possible related fix for this issue:

If it happened again in this version, please let me know.
I’m marking it as resolved for now.
Thanks again for reporting this!