Windows - Inkdrop Not Syncing

Bug report

I’m experiencing two issues with Inkdrop:
(1) My notes are not syncing. In the lower right of InkDrop, it says “Syncing…” but the notes never actually sync. I have tried restarting multiple times.
(2) I’m not able to install themes. It says “installing…” but never actually finishes.

Currently, I almost exclusively use this app on Windows. I do however have it installed on my Android.

Note: I’m currently in the free trial period of the app. I’m not sure if this matters.

I want to add, despite this setback, the experience I have had with notes I have been making has been wonderful. This tool is really awesome.


  • Platform: Windows

  • Platform version: Windows 10 (OS Build 19041.746)

  • App Version: (5.2.1)

  • Platform: Android

  • Platform version: 11

  • App Version: 4.0.3 (60)

I should add - I’m not behind a proxy of any kind.

Update x1:

  • I noticed the app wasn’t added to my Windows firewall list. I added it.
  • I noticed some of my notes synched. But not all of them.
  • I am still having issues downloading themes. My internet is 100mbs down and up, should I expect the installation of themes to take more than say 30 minutes?

Update x2:
I wanted to add, when I say “downloading themes”, I mean I go into the Inkdrop app on Windows, go to Preferences, Themes, Install a Theme, and then select Install from the list of themes for the one I want to install. This is where I’m noticing the installation gets hung up and I just see “Installing…”

Update x3:
Disabling the windows firewall still results in syncing getting stuck at “Syncing…” without actually syncing and installing themes also getting hung up at “Installing…”. Other websites load fine during this time. The issue seems isolated to this app.

Hi Nicholas,

Thank you for the report.
That’s weird. Looks like your network or firewall issue.
I checked the server logs and confirmed that the server got some requests from your client.
I can see there are 14 notes in the Inkdrop database at the moment.
Please allow * in your firewall.
I need to know what is blocking the requests.

First, let’s look into plugins.
Can you please try using ipm command from terminal to install themes? Here is the documentation:

If it failed to install, you should get some helpful error messages.
Then, please let me know the result.

Hi Takuya, thanks in advance for any help you can offer with the below.

Network issues
One of my notes, titled “2021.01.19_11.16AM_EST” was created an hour ago on my Windows dekstop.
I turned off Malwarebytes, and Windows firewall and rebooted.
Upon reboot (no firewall enabled, no virus protection enabled), I opened InkDrop on my Windows Desktop and synced my notes. I think it was still hanging on “Syncing…”. I’m not sure how long the “syncing…” process should take? I went for a 15 minute walk and it was still syncing.

I restartedmy Android and logged out. When I open InkDrop on my Android, it does not show the note titled “2021.01.19_11.16AM_EST”.

ipm install
When I try to install the nord-ui theme via the imp, the following happens:
I type this into the Windows terminal: ipm install nord-ui
The terminal responds with "Installing nord-ui to C:\Users\nshor\AppData\Roaming\inkdrop\packages
This message stays that way for over an hour

Looks like the requests are taking a very long time to reach the Inkdrop server from your network for some reason.
Can you please try sending an HTTPS request to the Inkdrop server manually with this command?

curl -v

If it works as expected, you should get a result like:

{"ok": true}

I’m not sure if this matters, but the firewall I use is Windows Defender. The antivirus is Malwarebytes.

I was able to get this printout from the command line without having to turn off either the firewall or the antivirus.

At the time of getting that above command line print out, the app still says “Syncing…” in the lower left hand corner


Thank you for the additional information.
That’s so weird. Interesting. So, your network is not blocking the requests to the server.
I need to know where the problem resides.
Could you try this also?

ipm install nord-ui --verbose

About 14 hours ago (from the time of this post) I was able to install the nord ui theme via the terminal:

I then tried to install another theme just a moment ago (the oceanic-next-mod-syntax):

The terminal seems to hang at the above, not going further.

I live in the United States in Florida (east coast).

If I cancel the installation when it gets hung on the terminal and try restarting, after about 5 to 10 tries it eventually installs. I’m not sure if that helps?

With Windows Defender Firewall, it only lets me add .exe files. I can’t add a phrase like “*”. Is there a specific set of executables I should add? Or should I switch to a different firewall that will let me add a phrase like that. Is there a firewall you would recommend?

Thank you for the report.
Hmm, it turns out that it’s hard to investigate from my side because the issue depends on your environment and is hard to reproduce in my environment.

I guess it is not due to the firewall because, if so, you should never be able to install any plugins or even log in to Inkdrop from the app.
The requests are intermittently delayed/blocked for some reason.
Sorry but I have no idea why it happens because the servers are working fine and no one except for you complains about it at the moment.
The API server is running on Heroku, which the instance is located in the US.

Please check your network configuration like DNS servers.
If I found anything regarding this issue, I’ll update it.

With Windows Defender, I couldn’t add a phrase like “*”. After doing all of the following, I was finally able to get InkDrop to work:

I used the option to “allow an app or feature through the Windows Defender firewall”, and I added this executable.

Then I also went to Advanced Settings and created inbound and outbound rules where I allowed both of these executables through on all ports:

  • %USERPROFILE%\AppData\Local\inkdrop\app-5.2.1\Inkdrop.exe
  • %USERPROFILE%\AppData\Local\inkdrop\Inkdrop.exe

I’m not sure if all of this is needed, but I figured I would report back in case this is of use to anyone else.

After the above, the app then started syncing and I now I see the synced notes on my Android as well as on the desktop.

I follow Julian Schrittwieser on twitter (Mu Zero, AI, Deep Learning). And he mentioned InkDrop and how one of the important things for a note taking app is “Does it Spark Joy”.
After briefly trying out several other note taking apps and being rather frustrated with their UI, I have to say InkDrop definitely hits that “does it spark joy” feeling when it comes to take notes. Because I like the UI and enjoy using the app, it makes such a difference to want to use it to take notes.

Thank you for such an awesome product. Thanks for your help and patience with my firewall issues.

1 Like

Hi Nicholas,

Great that you got it to work!
So, the requests have been blocked by the Windows Defender firewall and you managed to allow them by not specifying domains but the executable file path. Cool.
That’d be helpful for those who have a similar problem.
Thanks for letting me know that.

And glad to know it sparks your joy :wink: