Web Clipper not working


I am encountering an web clipper issue, and looking for advice on how to fix it

Failed to communicate with your local Inkdrop database API

Error: Failed to invoke the local database API - Failed to fetch

Please check Inkdrop is running, and check your server URL and credentials.

OS: Windows 11 22H2
Browser Microsoft Edge Version 106.0.1370.34 (Official build) (64-bit)

Hi Roy,

Looks like you set a wrong URL: locahost
It should be localhost

oh… typo. however, still the same problem after changing it

Can you provide the error message output in the developer console?

  1. Open chrome://extensions/
  2. Click “Details” button
  3. Click “service worker” link in the Inspect views section:

Can you make sure the server is working by running the following command?

curl -v http://username:password@localhost:19840/

The problem’s solved, after reboot the PC. somehow, I changed the username and password in the conf file, save it, and restart the inkdrop app, but it doesn’t take any effect, which I expected to.

Thanks for sharing curl way on checking the response. It guided me the auth is incorrect, then I checked the conf is correct as above mentioned, and I try to reboot the PC, it fixed.

1 Like