Unable to log in - Arch Linux - Failed to store user ID to Keychain

Bug report

When trying to sign into the application, upon hitting ‘Log in’, I get the following error:

Failed to store user ID to Keychain. Object does not exist at path “/org/freedesktop/secrets/collection/login”This is usually a permission issue and you may need to restart your computer. Please check your system configuration or report the problem.

I’ve restarted my computer, made sure the application is updated, even tried to run as root to see if permissions was the issue. None of these worked. Can anyone help with this issue?


  • Platform: Arch Linux
  • Platform version: 5.17.4-arch1-1
  • App Version: 5.5

How to reproduce

  1. Install from the AUR: paru -S inkdrop
  2. Open the application
  3. Try to sign in

Hi Braxton,

You have missing packages. Please check out the “Install Missing Packages on Linux” section in the troubleshooting:

Note that Arch Linux is not officially supported. So basically I can’t provide any specific steps for it.

I appreciate the help. I do believe I had all the correct packages, but I did manage to get it up and running by following these instructions from the ArchWiki regarding GNOME Keyring. Doing everything under the Using the keyring section, I was able to successfully log in!

Thank you for making such a wonderful application.

Thanks for the information!