Unable to export PDF of notes with iframe

Bug report

Exporting to pdf opens file dialog, but fails to generate PDF with following error message in the right bottom corner:
Bildschirmfoto von 2021-11-07 22-14-16

Developer console can’t be opened, but that’s another issue; starting inkdrop from the terminal and reproducing the bug produces less output than the error above.


  • Platform: Fedora Linux
  • Platform version: 35
  • App Version: 5.4.3

How to reproduce

File -> Export -> As PDF… -> Select location and hit save

Hi Noah,

Thank you for reporting it.
I found that it happens when using with Embed plugin. Otherwise, it works fine.
The plugin replaces contents like tweets with iframe, which Electron doesn’t allow for security reasons.
So, please try disabling plugins like Embed.
I’ll check if it’s possible to solve by using webview instead.

Hi Takuya,

I am sorry to report that I do NOT have the embed plugin installed. In fact, this is a fresh copy of Inkdrop and I am currently only evaluating it.
Bildschirmfoto von 2021-11-08 13-19-23

Disabling mermaid also didn’t help (I thought it may also be doing something with iframes).

That’s weird. I tried to reproduce it but couldn’t unless I used the Embed plugin.
Does it happen on every note? Or, do you find anything that would cause the issue?

Electron’s printToPdf API is quite unstable, unfortunately:

I try to keep my app’s Electron up-to-date as possible, and I hope it’ll eventually solve the issue.

Disabled every plugin except for “export print” and created a new note containing only two sentences. It still fails in the same way. In fact, Export --> Print lets me print to file from the OS, but that fails silently.

Wait… It’s not the printToPdf API. Starting inkdrop from the terminal with inkdrop --disable-seccomp-filter-sandbox fixes the issue and lets me both export to PDF and print.

Edit: According to several issue reports, this is required because the applications electron version is outdated: https://github.com/taw00/element-rpm/issues/50 https://github.com/vector-im/element-web/issues/19329

1 Like

Hi Noah,

Thanks for the information. That’s interesting.
I’m planning to upgrade the Electron version in the next release, so I hope it’ll be solved.

1 Like