TOC plugin not working


(Ed Kako) #1

Hello:

I’ve installed a number of plugins for Inkdrop. Most of them work just fine.

But I the Table of Contents plugin isn’t working at all. According to the plugins list in the Settings panel, it is installed, and I have seen no errors indicating that the plugin has failed to load.

However, when I type, for example:

# Table of Contents

Inkdrop does not generate a TOC below the heading.

I would appreciate any help trying to resolve this.


(Takuya Matsuyama) #2

Hi Edward,

Thank you for the question.
You have to write it as the second level heading:

## Table of Contents

Hope that helps.


(Takuya Matsuyama) #3

Hi Takuya,

Thanks for the message. I’ve tried writing it as a second level heading, but it still doesn’t work. No table of contents appears.

Would it help if I provided additional information? If that’s true, what more do you need to know?

Thanks,

–Ed

Please check out the example on the TOC page and compare what is different with yours.
And please tell me your reproduction code so that I can look into it.

It is helpful for others if you could reply me on this topic instead of email. Thanks for the cooperation!


(Ed Kako) #4

That worked! I had to execute the ipm install command. I thought I could simply place all the packages in the packages folder, but I was mistaken. Most plugins do work that way, but the TOC plugin does not.

Should all plugins be installed individually using the install command?.


(Takuya Matsuyama) #5

Good to hear that.

Yes, you always have to install plugins with ipm install command because some plugins have dependencies on other npm packages and ipm takes care of them.


(Ed Kako) #6

Thanks! That was very helpful.