Syncing (upload) never stops

Bug report

First of all: Love the app.

Whenever I open the app, there’s a lot of upload traffic. I can tell from the Mac Activity Monitor app that it’s Inkdrop that’s causing this activity. This doesn’t seem to go away regardless of how long I keep it running. I can tell from the bottom left of the app that it’s “syncing…” for a very long time, before stopping for a few seconds, before starting to sync again.

The developer tools contain no useful info, even when attempting to record the network traffic.

I have a feeling it’s probably a note that’s continuously failing to sync, which keeps retrying.
I would be happy to delete or remove this note, if only I could tell which one it was.
Are there any additional logs I can enable to try and debug?

Info

  • Platform: macOS definitely. Potentially also iOS, although I don’t know how to identify network usage.
  • Platform version: Mojave and Catalina
  • App Version: (4.3.4)

Reproduce

Unknown. I believe this started happening after migrating a lot of notes from another app (manually, nothing fancy going on). The posts were mainly small, but with some posts containing significant text AND images. I have since deleted all the images in all the notes I have in the app, thinking the size of images could cause the timeout, but the problem persists.

Hi Roger,

Thank you for the report.
That’s weird but I confirmed that socket hang up error happened while processing your sync requests.
Probably this is due to time out.
As you suspect, it might be because you imported a lot of notes at a time or added a large note that causes a large request to the server.
Inkdrop syncs not only current data but also change history (See here for more detail).
So deleting notes might not help.

You can get error logs regarding sync by launching it from terminal:

Inkdrop.app/Contents/MacOS/Inkdrop

I guess it can be solved by decreasing batch size of the request but it slows down the sync speed.
I will build a patch to check if it actually solves anyway.

Could you try it?

https://inkdrop-dist.s3-ap-northeast-1.amazonaws.com/beta/Inkdrop-4.4.0-beta.3-Mac.zip

Hi,

Thanks for the quick response.
I’ve tried running both versions through the terminal, but there are no useful logs and the problem persists, sadly.

Thank you for trying it.
I can see the server got the same error every minute.
That would take some time to inspect it.
I’ll work on it next week.
Thanks again for your support!

Is your network significantly slow?
The patch sends just two notes per request.
I don’t understand why it takes longer than 30 seconds.

Thanks. Take whatever time you need.
When syncing it’s uploading at more than 1 Mbps, so I don’t think that’s it. I don’t think I have any notes of that size.

Hi @Roger_Guldbrandsen,

Let me make sure first if it is really a time-out problem.
I built a temporary server to check it and a patch that communicates with it.
Could you try it?

https://inkdrop-dist.s3-ap-northeast-1.amazonaws.com/tmp/Inkdrop-4.4.0-Mac-patch-1.zip

Please let it run for at least 5 minutes.
Thanks for your support!

Done! It’s still happening however. Hopefully that gives you some more info to work on.

Thanks!
I found that your client is trying to send the image file but getting the request timed out from the database.
Please keep it running!

Gotcha!!!
You should see the sync finished?
It was due to the server misconfiguration (but not a problem for most users).
Now I stopped the debug server.
Please use the normal version of the app.

Thank you so much for your help :smiley:

Great! Looks like it’s fixed now.
おおきに!

1 Like