Some notes are missing even after synchronizing notes

Bug report

Some notes are missing (not shown in the list of notes) when I open Inkdrop on my mac book while these notes are visible on other devices including my desktop (mac pro) and iPhone.

The problem first occurred when I opened inkdrop under poor WiFi and it still remains even after the internet connection got stable. Although I did “Synchronize Notes” several times, the notes are still missing while the timestamp of “Synched at …” was updated. I don’t find any error in the console of Developer Tools.
Since it happens only on one of my devices, all the data are properly stored on the server. Perhaps, I guess some cached data might have inconsistency with the data on the cloud… Can we refresh the cached data?

Thank you in advance for your help. I’m enjoying using Inkdrop.

Info

  • Platform: macOS
  • Platform version: Catalina 10.15.7
  • App Version: 5.3.1

Reproduce

I don’t know how to reproduce it.

Hi Yohsuke,

Thank you for the report.
Okay, looks like something went wrong in the replication protocol.

Inkdrop’s replication protocol fetches the changes history as explained here in the PouchDB’s documentation.
So, can you please try editing the notes that are not synced? After that, please check if you can see them on the MacBook.

If you still don’t get them synced, please try full-sync by the following steps:

  1. Take a backup on the device that has all the notes
  2. On the MacBook, close Inkdrop
  3. Go to ~/Library/Application Support/inkdrop/
  4. rm -r db
  5. Launch it

Hope that helps.

Hi Takuya-san,

Since I had a number of missing notes, I simply removed the database and re-launched inkdrop after taking a backup. It worked like a charm. Thank you for your support.

Glad it worked!

I think it’d be nice to have a feature to replicate from scratch without deleting the local database to solve such an occational issue.
So, I keep this topic open for now.

Hi Takuya.
I ran into a similar issue when I use another mac that I occasionally use. Seemingly, some notebooks are missing from the list of notebooks (on the left panel) while the notes are there when I open “All Notes”.

I herewith attach a snapshot of one of the notes whose notebook is missing. I hope it helps you.
image

Hi Yohsuke,

Looks like the same replication issue.
The PouchDB/CouchDB checkpointer algorithm might have a bug.
I think replicating from scratch would solve this issue.
I built a quick fix for it here: https://inkdrop-dist.s3.ap-northeast-1.amazonaws.com/tmp/Inkdrop-5.3.1-x64-Mac_patch-1.zip
Can you please try it? Please don’t forget to take a backup before trying it.
You can re-sync data from scratch from menu File -> Synchronize Notes -> Full.
I’d like to know if this works.

Hi Takuya,

Sorry for my late reply. I’d like to try it but I don’t think I can do this for a while because the mac having this issue is in my office and I’m not commuting these days as working from home.
Nevertheless, thank you for preparing a hotfix and I’m looking forward to that feature being implemented in a future release.

1 Like

Sure, let me know if you had a chance to try it!