Snap with no visible letters in system dialogs on Fedora

Bug report

When using the Snap on Fedora the system dialogs don’t pick a correct font resulting in just squares.

Here for example the Export dialog:

I tried to reset the font caches as mentioned in other threads like this:

But this all has sadly not corrected this problem.


  • Platform: Fedora 32

Hi Marco,

That’s strange and looks hard to investigate in my environment.
Do other Electron-based snap apps work correctly, like GitKraken?
I found a thread related to this issue:

Hi Takuya and thank you for having a look.

In this thread sadly they point to the user that they delete their font caches. Sadly this doesn’t work.

I also tried to delete the caches in ~/snap/inkdrop/common/.cache/fontconfig/
Also I tried to remove the configs from ~/snap/inkdrop/common/.config/fontconfig/ without success

For Chromium at least that I have installed as a snap the dialog boxes look okay there.

But oh I see you also have an .rpm to download. Then I will propably use this one.

But wait, it seems a general issue with Fedora and snaps - even the Snap Store app does not look good everywhere.

Here as screenshot when I want to remove the Chromium snap.

So the issue is likely not on your side :+1:

Looks like so.
Electron had the same issue but it’s been solved 3 years ago:

There might be a regression in the recent version but I couldn’t find that.
I suspect that it has something to do with your locale? Try changing the system language to en_US or something.

My locale is set to en_US. I’m looking through other Manjaro settings as recommended by the Arch wiki for anything that could be over riding it.

No success yet.

I had success with the following:

$ rm -f ./snap/inkdrop/common/.cache/fontconfig/*
$ rm -f ./snap/inkdrop/current/.cache/fontconfig/*

# this appears to be the key
$ snap run --shell inkdrop
$ fc-cache -r
$ exit

Let me know if this works for you


Thanks, @John_Kelley. I’ll give that a try in the morning. I had deleted and reinstalled fontconfig, but system wide, not within snap. This is a much more complete solution. I’ll report on my progress tomorrow.

@John_Kelley … that worked BEAUTIFULLY! The dialogue box now shows all the proper text. Thank you!!

1 Like

That’s great news @Rich_Cook, I’m glad I could help!

Cool! Thank you, @John_Kelley.
I marked your post as a solution.