Pushing notes to CouchDB stopped working

Bug report

Hello, I am using Inkdrop on 4 devices - macOS, windows, Linux (snap) and iOS. The Windows one stopped synchronizing the notes with my CouchDB server. Interesting thing is, that pulling new notes from DB is working, but pushing notes to it is not. I have checked the DB mannualy, and new notes from windows machine are not there. When I create a new note on other device, this gets updated also on the windows machine. Few days ago, everything worked fine.

The synchronization between other devices is working fine. I have tried to: re-install app, restart PC, synchronize notes from scratch, and other things in troubleshooting. DevTools shows 1 error: The vm module of Node.js is deprecated in the renderer process and will be removed., and few warnings of this type DevTools failed to load source map: Could not parse content for file:///<path-to-user-home>/AppData/Local/inkdrop/app-5.5.3/resources/app.asar/code.js.map: Unexpected end of JSON input.

Is there something else I can check?


  • Platform: Windows
  • Platform version: 11 Pro
  • App Version: 5.5.3 (app says it is the latest version)

How to reproduce

Hi Ondrej,

  1. Have you looked into the server logs of CouchDB? Are there any errors?
  2. Also, you can try enabling logs: Troubleshooting
  3. You’ve tried reinstalling the app. Have you checked your data directory, especially, the db folder, was removed when uninstalling?

Hi Takuya,

thanks for the reply.

  1. The CouchDB logs did not reveal anything useful, other than, that the windows machine was trying to synchronize every 2 seconds, which was weird
  2. After enabling logs there were some “permission denied” errors
  3. I have uninstalled the app, and then cleared all the left over files. That means %APPDATA%\Local\inkdrop\ and also %APPDATA%\Roaming\inkdrop.

After this the synchronization works as expected. Thank you very much.

1 Like

Great to know that it’s been resolved, and thanks for the report!