Port to RPM based Linux e.g. Fedora

Are there any plans to port/recompile Inkdrop over to RPM based Linux distros, I primarily use Mac and Fedora as my main systems and would really love to use Indrop on all my platforms, unless I am missing something the only Linux release I see is for Ubuntu.



Hi Phillip,

Thank you for the suggestion.
It may be possible to get it to work on Fedora 21 as the Electron’s document says: https://github.com/electron/electron/blob/master/docs/tutorial/supported-platforms.md
But its build process is unofficial, so I can’t promise to roll out RPM packages for now.
Because it’s hard to check if each release works correctly on the various systems.
Anyway, I’ll look into it. Thanks!

Hi @Phillip_Easterbrook,

I just built a rpm package: https://d3ip0rje8grhnl.cloudfront.net/v3.12.0/inkdrop-3.12.0.amd64.rpm
Could you try it?
It should work on Fedora 21.


I responded back via email, but I’ll post here, after installing lsb as a dependency on Fedora 26, Inkdrop is now running on my Linux system,

Thank-you very much for working on this.

Thanks for checking it and happy to know it worked!
I’d like to know lsb is necessary to install manually for other people.

Now I’ll mark this topic as resolved but feel free to comment here for further information.
Thanks for the suggestion!

Good day!

Tried installing it on Fedora 27 using sudo dnf install inkdrop-3.15.0.amd64.rpm but I get the following error:

Problem: conflicting requests

  • package inkdrop-3.15.0-1.amd64 does not have a compatible architecture

After reading this post, I decided to install lsb but the error persists.

One thing I noticed was that uname gives the following:

Linux desktop 4.13.16-300.fc27.x86_64 #1 SMP Mon Nov 27 18:19:43 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Would a possible cause be that the architecture referenced by the inkdrop package, amd64, is different than x86_64, as shown above? I was under the impression both would be compatible with each other.

EDIT: I got it working using sudo rpm -ivh inkdrop-3.15.0.amd64.rpm.


Yeah, there is no difference between x86_64 and amd64 but some people have similar issue:

I built it for x86_64: https://d3ip0rje8grhnl.cloudfront.net/v3.16.0/inkdrop-3.16.0.x86_64.rpm
Could you check if it works with both dnf and rpm commands?

1 Like

Hi ! Both the dnf and the rpm installation commands are working with the version you supplied. Thanks a lot for looking into this!! :slight_smile:

Great! I’ll build the rpm package for x86_64 from next version. Thanks for the report!

1 Like

Do you create your own RPM SPEC files? If so, I know there’s a compat command to indicate compatible architectures. I haven’t read all the documentation, but I’m thinking that perhaps it would allow you to build only once while supporting multiple architectures. Reference: http://ftp.rpm.org/max-rpm/s1-rpm-multi-build-install-detection.html

Thanks for the tip!
I’m using electron-installer-redhat for building rpm packages. I guess amd64 was wrong because x86_64 is specified in the documentation.


To install on fedora with dnf/yum

  • Download the rpm package
  • got to the download folder
  • sudo dnf install ./package name.rpm
  • sudo yum install ./package name.rpm
1 Like

Why not create a snap package for inkdrop? Then it should work on essentially all Linux distros. For example, this is the way Spotify do it. Much less work, I should think.

1 Like

Yeah, I’ll look into it. Thank you!