Pasting image from clipboard broke sync

Bug report


I created a note with a TODO list and also included a small screenshot pasted from clipboard. This was on Mac. I then noticed the note didn’t appear on my computer with Windows (second instance of Inkdrop running there). I tried all various ‘sync’ buttons and nothing worked. I tried creating a new note (on Mac) just with a single word, pressed sync and that note synced and appeared on Windows immediately. I also created a test note on Windows and it appeared on Mac fine so the basic sync alone worked fine.

I then tried duplicating the note that wouldn’t sync and the duplicated one did sync. The problem is, the attached screenshot isn’t there. I checked the dev tools (on Windows) and saw this:

The text in note itself shows - ![clipboard.png](inkdrop://file:kJMEy6_mw)

My questions:
1.) Why did the sync status report acted like everything is OK? (It is possible I will be syncing a lot of notes to a new machine in future and I won’t even realize some of them are missing if these issues aren’t reported somewhere.)
2.) Do I need to handle images in notes in a specific way to make them sync?


  • Platform: macOS and Windows
  • Platform version: macOS Big Sur 11.6.5 and Windows 10 (updated)
  • App Version: 5.5.1

How to reproduce

  1. Write a new note on macOS (I had a TODO list with ~30 items)
  2. Paste an image from clipboard somewhere between the TODO list items.
  3. Save note.
  4. Open InkDrop on Windows.
  5. The new note doesn’t appear and no error is shown (well, it might appear in dev. console but I am not having that open all the time… :slight_smile: )

Hi Petr,

Thanks for the report. That’s weird.
I have a bunch of screenshots pasted to my notes on macOS and they are displayed on Windows fine.
Maybe something went wrong on Windows but I have no idea at the moment.
Are other image files except screenshots synced properly?

1.) Why did the sync status report acted like everything is OK?

The sync fails for various reasons like network issues, and that’s annoying to report every single error.
If there was a sync error, it simply retries automatically.

2.) Do I need to handle images in notes in a specific way to make them sync?


I need to reproduce this to fix it.
Have you tried Help → Synchronize Notes from Scratch (See the doc for more detail) on the Windows machine?
If it doesn’t solve the issue, could you please report what you get by following the steps?

  1. Open the Developer Tools on macOS
  2. Run the following JS in the console:
  await inkdrop.main.dataStore.local.files.get('file:kJMEy6_mw'), null, 4

and let me know the output.

  1. repeat that on Windows


Thank you for the response. Unfortunately, I found that I deleted the old note so I couldn’t try the steps you proposed… Actually, just realized there’s a Trash bin :slight_smile: I found the old note in there and it is showing the image!

So… I don’t know. It must have been some temporary/one-off glitch that happened. I just tested with a new note with image from clipboard and that synced just fine.

I will report back if it happens again. For now, I guess there’s probably nothing I can do to help investigate so we can close this.

Thank you.

1 Like

Okay, thanks for letting me know that!