[Mobile beta v5.0.0 (20)] In the Default Light UI theme, the scroll bars are not visible

Bug report

Dark UI themes are not a problem. White scrollbars are shown. However, the light UI theme also shows a white scrollbar.

Please check.


  • Platform: iOS
  • Platform version: 16.3.1
  • App Version: 5.0.0(20)

How to reproduce

Type long sentences in the Default Light UI theme.

Hi Daiki,

Thanks for the report.
The issue resides both in the native and webview sides.
Scroll bars basically follow the system appearance settings, which won’t change automatically based on background colors.
I guess you are in dark mode, and that’s why the scroll bars disappear.
On the native side, it could be resolved by manually specifying scroll indicator colors for each component.
However, based on my brief research, changing the indicator color of the overflow panes seems impossible, unfortunately.

Can you tell me why you’d prefer using the light UI theme, while in dark mode?

1 Like

Hi Takuya,

I didn’t realize it was a setting on the iPhone itself. Thanks for letting me know :slight_smile:

I basically use my iPhone in dark mode. However, when the screen is difficult to see in a bright place, I switch to light mode.
I always switched to light mode only on the Inkdrop side.
When I put the iPhone in light mode, I could see the scroll bars. Thank you very much :+1:

As a side note, the github mobile app shows scrollbars in the in-app only setting. I have no experience in mobile development, so I don’t know, but it would be great if webview would support it as well.