Mac app crashing right after update

bug

(Bruno Del Frate) #1

Bug report

I’ve updated the Mac app for Inkdrop to the latest version, and now the app crashes during startup, every time I run it.
Full crash report is here: https://pastebin.com/TP70hpLb

Info

  • Platform: macOS
  • Platform version: Mojave 10.14.2
  • App Version: the latest for Mac

Reproduce

Use the automatic updater to update the app to the latest version, then launch the app.


(Takuya Matsuyama) #2

Sorry, I forgot to rebuild the native modules.
I rebuilt the app.
Please download the app again:

https://s3-ap-northeast-1.amazonaws.com/inkdrop-dist/v3.25.0/Inkdrop-3.25.0-Mac.zip

Sorry for the trouble!


(Bruno Del Frate) #3

Thanks, Takuya. I’ve installed the updated build, but unfortunately now it’s showing me a new error:


(Takuya Matsuyama) #4

Could you make sure the duplicate Inkdrop process doesn’t exist?


(Bruno Del Frate) #5

There’s no other Inkdrop process running. I’ve also rebooted, just to be sure.


(Takuya Matsuyama) #6

I suspect that the db lock file has not been released by the broken app. Do you mean you rebooted your computer?


(Bruno Del Frate) #7

Yep, that’s what I meant.


(Takuya Matsuyama) #8

Please try moving your local db stored in:

/Users/<username>/Library/Application Support/inkdrop/db/<user-id>

to other place.
Then, start the app and it will sync from scratch.


(Bruno Del Frate) #9

Thanks for your help, Takuya. Unfortunately I didn’t test this, as I’ve been able to solve my problem before reading your reply. Here’s what I did.
I’ve removed all tracks of my Inkdrop installation with Appcleaner.
I’ve reinstalled version 3.24, then I updated again. Now everything works perfectly!
Thanks for your help!


(Takuya Matsuyama) #10

Great to hear that.
That makes sense.
I guess Appcleaner deleted your local db.
Thank you for letting me know!


(Takuya Matsuyama) #11

I added a build step to run electron-rebuild in order not to make the same mistake again.
Thanks again!


(Samantha Zhang) #12

Had the same bug and tried deleting ~/Library/Application Support/inkdrop and reinstalling v3.25.2, didn’t work. Had the same database error. Downloading v3.24.0 worked.

Also just a side note - maybe it’s good to have a web version for Inkdrop as a last resort?


(Takuya Matsuyama) #13

Hi @Samantha_Zhang,

That’s weird. I tried to reproduce it but couldn’t.
Maybe other problem?

I’m afraid that the web version will not be available.
Because it’s hard to keep it well-maintained since I rarely use it.


(Samantha Zhang) #14

Not very likely … I tried multiple times … did you use with the broken update?

I thought you use something like React Native to make the app and thought a web version would just be another export … maybe not :joy:


(Takuya Matsuyama) #15

I deleted ~/Library/Application Support/inkdrop and launch the app again, and it worked without db error.

Yeah, the mobile version is built on top of React Native but it doesn’t work on the web out of the box…it requires a lot of work.


(Samantha Zhang) #16

I think it has something to do with the broken update we’ve got.

Maybe install that version, then delete the folder, and install the fixed v3.25.2?


(Takuya Matsuyama) #17

Sorry, I no longer have the broken binary. :sweat:


(Samantha Zhang) #18

okay then :joy: