Linux installation via package manager


(Dan Bohea) #21

I did have to specify --stable to pickup the update. Inkdrop launched fine after a successful download.

I’m now seeing what looks to be GTK3 UI (launched from Preferences > Backup location) but it’s using a light theme (Inkdrop GTK seems to be ignoring my OS prefs). The same appears to be true of the application menu below the application title.

By comparison, GitKraken, Slack and VS Code all seem to respect the OS preferences for a dark GTK theme (all Electron apps as I’m sure you’re aware) but I’m unsure if these are defaults for those apps or whether they truly are respecting the OS prefs for a dark GTK theme.


(Takuya Matsuyama) #22

Thanks for the report.
On my Ubuntu 18.04, it seems that the app respects a dark GTK theme:

But I’ve installed it from deb package, so it might be a snap app problem.
Did you install other apps via snap?


(Dan Bohea) #23

Yes, that’s what I’m trying to say. Before running Inkdrop via snap I ran it from the .deb installation which respected the dark GTK theme prefs. I’ve only started seeing this issue since I installed via snap.

My Slack installation is via snap and that has a dark theme app menu though I’m not 100% if this is just always the case in Slack, irrespective of what theme prefs are set in the OS.


(Takuya Matsuyama) #24

I also tried the snap app but confirmed that it respected the dark theme as expected.
I’m not sure why it won’t work in your environment.