Keybindings with numbers and the shift modifier together do not work

Bug report

Currently keybindings cannot contain numbers with the shift modifier together in one keybinding (eg. ctrl-shift-2)

Therefore the default keybindings for changing the note status also dont work.

I have tried to use the character in the keybinding that appears when using shift and the number (eg. shift-1! - german keyboard layout) as this is the case when using the shift modifier with an alphabetic character (eg. shift-K)


  • Platform: Windows, Ubuntu
  • Platform version: 11, 22.04
  • App Version: v5.8.0-beta.1

How to reproduce

These are a few keybindings that i have used for some testing.

not working keybindings:


Hi Lukas,

Thanks for the report.
I looked into the source code of the Atom’s keymap module and found that it is intended:

It converts characters to the ‘with-shift’ ones if the shift key is held down.

But I guess it could be resolved by converting characters when normalizing a keystroke here:

I’ll try it.

Can you try this patch?

Thanks, it looks like it works with the patch.
I have tried this successfully with the following keybindings:


Great! Thanks for testing.