"Just start typing" is shown when deleting unfixed text by back space key


Thank you for developing the great app!
I enjoy using it everyday.

I am using it on Windows with Japanese input. When I type Japanese text and backspace it before fixing the convert (Kanji, Katakana etc), the “Just start typing” message is shown together with other text I typed.



  • Platform: (Windows)
  • Platform version: (Windows 10 Pro)
  • App Version: (5.2.0-beta.1)


  • Type several line.
  • In a new line type Japanese with IME input.
  • Before fixing the character, delete the text.

Hi Akira-san,

Thank you for reporting it.
But I couldn’t reproduce it on my Windows 10 environment.
I use the default Japanese IME.
When I type several Japanese characters and hit the spacebar, the composition starts, then hit the backspace key, but the placeholder is still hidden as expected.
I guess you are using a third-party IME or something?

1 Like

Hi Takuya-san,

Thank you for your quick response!

I also use default Japanese IME.
I attach some screenshots for your reference.

Hope we can fix it.

inputs I am using

Got it to reproduce!
I found that it is a CodeMirror’s bug.
Luckily, it seems that the issue has been just solved 13 days ago:

I confirmed that updating CodeMirror to the latest version solved it.
It will be landed in the next release.
Thanks again for the detailed report!

Hi, Takuya-san,

Glad to know that I am not alone having this issue and it will be fixed soon.
Thank you for solving the issue!
Looking forward to using the new version.

1 Like

Fixed in v5.2.0-beta.2 :tada:
Thanks again for reporting!

1 Like

I confirmed that the issue is solved with the beta.2. Thanks Takuya! :laughing: