Installing Inkdrop on Ubuntu 14.04


(Thomas Roddick) #1

Bug report

I installed the client app from a .deb package, however running inkdrop from command line yields the following error message:

  app:error Failed to init app: Error: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /tmp/.org.chromium.Chromium.fnQzAT)
  at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:173:20)
  at Object.Module._extensions..node (module.js:598:18)
  at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:187:18)
  at Module.load (module.js:488:32)
  at tryModuleLoad (module.js:447:12)
  at Function.Module._load (module.js:439:3)
  at Module.require (module.js:498:17)
  at require (internal/module.js:20:19)
  at Object.<anonymous> (/usr/lib/inkdrop/resources/app.asar/node_modules/keytar/lib/keytar.js:4:12)
  at Object.<anonymous> (/usr/lib/inkdrop/resources/app.asar/node_modules/keytar/lib/keytar.js:58:4)
  at Object.<anonymous> (/usr/lib/inkdrop/resources/app.asar/node_modules/keytar/lib/keytar.js:60:3)
  at Module._compile (module.js:571:32)
  at Object.value [as .js] (/usr/lib/inkdrop/resources/app.asar/main.js:1:37003)
  at Module.load (module.js:488:32)
  at tryModuleLoad (module.js:447:12)
  at Function.Module._load (module.js:439:3)
  at Module.require (module.js:498:17)
  at require (internal/module.js:20:19)
  at Object.defineProperty.value (/usr/lib/inkdrop/resources/app.asar/main.js:1:106995)
  at t (/usr/lib/inkdrop/resources/app.asar/main.js:1:276)
  at Object.defineProperty.value (/usr/lib/inkdrop/resources/app.asar/main.js:1:101448)
  at t (/usr/lib/inkdrop/resources/app.asar/main.js:1:276)
  at w.init (/usr/lib/inkdrop/resources/app.asar/main.js:1:11024)
  at App.i.app.makeSingleInstance.i.app.on (/usr/lib/inkdrop/resources/app.asar/main.js:1:9947)
  at emitTwo (events.js:111:20)
  at App.emit (events.js:194:7)
 +0ms
  Rollbar:error Received error: Over free plan monthly limit. Project id 57343 access token b1af6b4a263447d8963dfe2650804b29. +0ms

I’ve tried a few solutions online for errors related to libstdc++ (e.g. https://github.com/BVLC/caffe/issues/4953, https://askubuntu.com/questions/575505/glibcxx-3-4-20-not-found-how-to-fix-this-error), however none of these seemed to fix the issue in this case.

Info

  • Platform: (Ubuntu)
  • Platform version: (14.04)
  • App Version: (3.9.0)

Reproduce

  1. Download the .deb package from https://d3ip0rje8grhnl.cloudfront.net/v3.14.2/inkdrop_3.14.2_amd64.deb
  2. Install using dpkg -i /path/to/inkdrop_3.14.2_amd64.deb
  3. Start app from terminal using inkdrop

(Takuya Matsuyama) #2

Hi Thomas,

Thank you for reporting.
The recommended environment is Ubuntu 16.04 because the binary for linux is built on it.
I’ve also got a report that it won’t run on Debian 8.x due to similar problem from some people.
Seems like I have to build it on older environment in order to avoid this error.

I’ll look into it.
Thanks again!


(Thomas Roddick) #3

Hi Takuya,

Thanks so much for your help! I’ll give it a try on 16.04, but please let me know if you manage to get it running on 14.04!


(Takuya Matsuyama) #4

Hi,

Could you try this binary?
I built it on Ubuntu 12.04 so I guess it should work.
https://d3ip0rje8grhnl.cloudfront.net/v3.14.2/inkdrop_3.14.2_amd64_2.deb


(Thomas Roddick) #5

It worked! Thanks so much!

When I originally installed using dpkg the installation failed with this error:

dpkg: dependency problems prevent configuration of inkdrop:
 inkdrop depends on libgconf2-4; however:
  Package libgconf2-4 is not installed.

but installing libgconf2-4 fixed the problem right away.


(Thomas Roddick) #6

Although that said I seem to be having another problem with this build where the enter key doesn’t insert a new line (although shift-enter does). I’ve not played around with the keymaps at all, so could this be related to the platform?


(Takuya Matsuyama) #7

that’s weird, i’ll check it. thanks for reporting!


(Takuya Matsuyama) #8

The dependency on libgconf2-4 is intended, it is for the latest electron.
I fixed the return key problem. This was due to an un-released change for the new version. Could you try it again with this binary?


(Thomas Roddick) #9

Great, that seems to have fixed the problem! Thanks for your help!


(Takuya Matsuyama) #10

Glad to hear that!
Okay, I’ll keep building it on Ubuntu 12.04 from next version.