Inkdrop web clipper

Bug report

Unable to install web-clipper via ipm
“No available version compatible with the installed Inkdrop version: 4.3.4”


Windows 10 1903, latest version of inkdrop


Unable to install web-clipper via ipm

1 Like

Hi Erik,

Thank you for reporting.
I’m afraid that the plugin is not made by me but a user.
Please ask the author to update it on its GitHub repository.

Anyone have the author’s info?

I created a pull request to fix the web-clipper plugin.

The only issue I had during the migration to inkdrop 4 is changing the selected note in inkdrop?

I tried using the action but am not sure what parameters it requires:

Great work, andi!
If you would like to open an existing note, please use core:open-note command like so:

inkdrop.commands.dispatch(document.body, "core:open-note", {
  noteId: "note:uugSvPq5r",


Looks like the original author of the plugin is inactive now.
I’ve removed it from ipm, so could you publish it as a new owner please?

Sure, should be available now:


Cool! Thanks so much

The official web clipper is now available for the paid users!

Currently in beta but it’ll be officially rolled out soon :raised_hands:

Bug(?)/problem with beta Inkdrop install
Env: Windows 7, Vivaldi (Chrome), and Inkdrop 5.2.1

Attempted to install/use web clipper.

Instructions say first to use beta (5.3), I did not do this first. I did this last.

Installed chrome extension, modified the config.cson file, set the parameters in the chrome extension, restarted Inkdrop, restarted Chrome, attempted to use web-clip.
I see the markdown/code for a second, then error pops up “Failed to invoke the local database API - Failed to fetch”.
Check config.cson file, database info is there (used same as example, different user/pass).

Realize I didn’t do step 1, install beta 5.3.
Download, start install - then get an error - “EPERM: operation not permitted, rmdir ‘B:$RECYCLE.BIN’”
B-drive is not ‘main’ drive for install/operating system/User-data.
C-drive is actual OS/User location (C:/Users/[me]/AppData/[Roaming/Local]/inkdrop/)
Not sure why it is looking at B (first letter?, do not have an A:), it left files/folders on B (_deleted, data, state).

Restart computer. Re-install non-beta Inkdrop (5.2.1), everything loads and works fine.
Got the Inkdrop popup to upgrade version to 5.3. Try to upgrade to 5.3, same error.
Reinstall non-beta 5.2, everything loads and works fine.

I’m perfectly happy using 5.2.1, I was trying web-clipper for fun, I did not expect to use it often.
However, this info might be useful!

Hi Emily,

Thanks for the report.
That seems to be a bug in v5.3.0-beta.1 regarding the backup feature.
What does your backup path look like in your config.cson?

It does have B, I probably set that and don’t remember!
backupPath: “B:\”

@Emily_DeJoode Thanks for letting me know! Okay, that was a config issue. So, does the beta version work well with the correct path?

Yes! Thanks.

1 Like

Cool! Thanks for letting me know.

The web clipper is officially available now in v5.3.0🎉