Inkdrop shows Error Unexpected account status

Bug report

I tried to launch Inkdrop app, and app shows below error message.

Unexpected account status

then, I cannot edit notes and logout.
I use inkdrop at my company and network is under proxy. So I set proxy setting to setting.cson.
Till day before yesterday, Inkdrop app works fine.

is there something setting to avoid this error?
or what does mean this error message?


  • Platform: (Windows)
  • Platform version: (10)
  • App Version: (3.25.4)


Today, I tried to launch app with the non-proxy environment via wifi. and this works fine.
Then I add proxy setting to my config.cson and re-launch Inkdrop app. In this situation the app always shows same error.
Also I try to remve AppData\Roaming\Inkdrop directory and re-generate it by app, but same error is shown.

Hi Hideki,

Thank you for the report.
I guess the issue is related to this one: I can't log in : ssl3_get_record: wrong version
Does your proxy server support TLSv1.2?


Thank you for your reply.

I asked to network administrator of my company, His reply was that the proxy server is appliance and maybe support TLS1.x.
So, I tested my env with TLS testing tool.
Below Test shows “Your client is using TLS 1.3, the most modern version of the encryption protocol.”, so I concider that the proxy server is also supporting TLS 1.2.

On the other hand, I tried to your test code at here.

$ node -v
$ node test.js
error: null
statusCode: 200
body: {"ok":true}

It works, and there’s no problem with electron…?

OK, thanks for letting me know.
So I suspect that it causes axios@0.19.0-beta.1 which is used in the latest version as I found it would solve the old SSL issue in that topic.
If so, seems like I should revert the version to 0.18.
Since I don’t have a corporate proxy, it’s quite messy to support.

I’ll build a patched version. Please hold on.

I built it with axios@0.18.
Could you try it?

I tried yout patch.
I am sorry for late reply…

It seems working fine.
I comfirmed these points:

  • Inkdrop app shows no error message.
  • my text is synced between your patch(under proxy network) and iPhone app.

Thank you for your quick response!

1 Like

Thank you for letting me know!
That’s great to hear and I will use 0.18 in the future release.
Thanks again!