Inkdrop freeze completely after adding large file

Bug report

After adding a large log file to Inkdrop as a note, the user interface has become completely unresponsive for 30 minutes. I cannot click on anything, so I cannot delete the note, and I cannot even open Developer Tools.

There is a spinner in the search input field. CPU usage for Inkdrop Helper (Renderer) is at ~ 105%. Memory usage is quite low (~100-200 MB).

If I quit and restart Inkdrop, it just hangs in the same way from start.

Since I’m not able to use Inkdrop nor remove the problematic note, I wonder if it’s possible to manually delete the file directly from Inkdrop’s SQLite database? I will of course make a backup first, but is there anything special I should consider if I try?


  • Platform: macOS
  • Platform version: 12.5
  • App Version: 5.5.1

Hi Dan,

Thanks for the report.
How large is the note?
I suspect that the Markdown renderer is hanging up due to its size as you are seeing the renderer process has a high CPU usage.
Is it still unresponsive after 30 minutes?

For a workaround, the app tries to open the last opened note on launch. You can change it by editing the config.cson in the user data directory like so:

      editingNoteId: "foo"

It’s ok to specify the id that doesn’t exist. Now, the app just fails to open it up but you can avoid opening the huge note.
Can you please try it? Hope it works.

1 Like

Awesome, thanks, that worked – I was now able to open Inkdrop, right-click the note and move it to Trash without opening it!

The note was 886 kB, so I’m not sure if it was the size of it that made it freeze, after all, or rather something about its content. It’s not sensitive, so I can send it to you if you like to test it, just let me know how.

Great to hear that it worked!
886kb sounds huge. That makes sense. I guess that was a server log or something like that.
Maybe the app should warn when pasting a large text.
Thanks again for the feedback!