Inkdrop crashes on quit on Windows 8.1

Bug report

I noticed that when closing the application, it closes incorrectly. I noticed this from the event log and the presence of dumps in the folder %localappdata%\CrashDumps.

Info

  • Platform: Windows
  • Platform version: 10 Pro 21H1 (build 19043.1110)
  • App Version: 5.3.1

Reproduce

  • Install Inkdrop v5.3.0
  • Log in and sync notes
  • Update to v5.3.1

After that, the crash records appear in the event log (Windows Logs\Application) after application is closed.

Hi Dmitriy,

Thank you for reporting it here!
Okay, let’s look into it.
You also reported that you are on a virtual machine. Which VM software do you use?
I guess that should be something to do with this issue.
Could you try running Inkdrop with console output enabled?

\path\to\Inkdrop.exe --enable-logging

Then, do you get any errors when quitting it?

The application crashes on the host. I was just able to reproduce it on a virtual machine as well.

Which VM software do you use?

VMware Workstation Pro 15.5.7

Inkdrop.exe --enable-logging
[bugsnag] Loaded!
2021-08-02T07:23:19.399Z app:info Initializing inkdrop app..
2021-08-02T07:23:19.416Z app:info Arguments: C:\Users\User\AppData\Local\inkdrop\app-5.3.1\Inkdrop.exe
2021-08-02T07:23:19.421Z app:info Arguments: --enable-logging
2021-08-02T07:23:19.556Z app:info Starting inkdrop app..
2021-08-02T07:23:19.630Z app:info axios default config: { proxy: false, httpAgent: undefined, httpsAgent: undefined }
[6488:0802/102320.705:INFO:CONSOLE(13)] "(electron) The remote module is deprecated. Use https://github.com/electron/remote instead.", source: electron/js2c/renderer_init.js (13)
[6488:0802/102321.044:INFO:CONSOLE(45511)] "[bugsnag] Loaded!", source: <embedded> (45511)
[6488:0802/102321.318:INFO:CONSOLE(44454)] "The vm module of Node.js is deprecated in the renderer process and will be removed.", source: <embedded> (44454)
(node:4080) Electron: Loading non-context-aware native module in renderer: '\\?\C:\Users\User\AppData\Local\Temp\6ae24a2d-d359-40cb-9f96-05903bb28887.tmp.node'. This is deprecated, see https://github.com/electron/electron/issues/18397.
(Use `Inkdrop --trace-warnings ...` to show where the warning was created)
2021-08-02T07:23:52.452Z app:info Unloading app
[6488:0802/102352.570:ERROR:node_bindings.cc(147)] Fatal error in V8: v8::ToLocalChecked Empty MaybeLocal.

No error messages. Only in the event log.

Thanks for the log.
Ok, it happens on both host and vm.
So, it looks like no errors happen in the application layer.
I guess it’s an Electron’s bug or something.
Since I can’t reproduce it in my environment, it’s hard to solve at the moment.
Do you find anything helpful in crash dumps? Could you show me it?

Windows 8.1 Pro

2021-08-05_103026

  1. Download Inkdrop-5.3.1-Windows.zip
  2. Launch & close app

Hmm, unfortunately, that’s not helpful to find the issue.
I need to know why it crashed, something like call stack so that I can investigate deeper.
I checked the issues of Electron on GitHub but can’t find possible issues at the moment:

Please let me know if you found any further information.

Can’t reproduce crash on Windows 8.1 Pro too?
Stacktraces are not being sent to Bugsnag?

I’m afraid that I have only Windows 10 Pro.
But I haven’t ever got such a report when 8.1 was the latest.
Yes, Bugsnag doesn’t catch the crash as it doesn’t happen in the application layer but the native layer.
If possible, please check if it also happens when running on another machine.
Plugins could cause the crash. Please try disabling them.

Got it to reproduce on Windows Server 2016.
The error is:

[4532:0806/123834.357:ERROR:node_bindings.cc(147)] Fatal error in V8: v8::ToLocalChecked Empty MaybeLocal.

I also found that it doesn’t happen when logged out.
As the error comes from node_bindings.cc, it should be due to a native module.
I’ll look into it.
Interestingly, it doesn’t happen when logged out.
So, I suspect that some cleaning up process would be causing it.

I was missing that you also have the same error log that you’ve reported. Sorry!

Could you try this build? I guess it should fix the issue.

Unfortunately, this build did not solve the problem.
But I noticed that when closing the application by Alt+F4, it does not crash so often.

Do you see the following error log with the build?

[6488:0802/102352.570:ERROR:node_bindings.cc(147)] Fatal error in V8: v8::ToLocalChecked Empty MaybeLocal.

If not, at least, the error has been fixed.
It looks like the crash happens due to another reason, which I have no idea why at the moment.

Yes, this error still occurs in new build.

Okay, it happens randomly. So weird…:thinking:

I revised the clean-up code.
How about this patch? https://inkdrop-dist.s3.ap-northeast-1.amazonaws.com/tmp/Inkdrop-5.3.1-Windows-patch-2.zip
Please let me know if you still get the error.
Thanks for your patience!

There are no crashes (and no error messages in log) in this build.

Great!!

landed in v5.4.0:tada: Thanks again for the report!