How to install plugins?

Hi,

How do I install plugins? Are there any guides for this already existing?

I had a look, and all I could find was an apm fork for ipm, that I had to build myself. The build script stopped working (just hung at the download node bundle stage), and the README.md for it was for apm (not rewritten for imp). On linux, in the inkdrop app menu I see plugins, but when I try to click it no menu appears.

Would appreciate any help with this. Thanks in advance.

Best,

  • Robert

Hi Robert,

Thank you for the question.
Here is the documentation about installing plugins: https://doc.inkdrop.info/manual/extend-inkdrop-with-plugins
You don’t need to build ipm by yourself. It’s bundled with the app.

Hope it helps!

Hi craftzdog,

That’s very helpful, thanks. On Linux I can however not see Preferences > Plugins in the menu. I checked under File, and I can see no Preferences entry. There is a menu title for Plugins, but the submenu does not appear when I hover over it.

Am I missing something in the Linux menu?

Sorry for the confusion.

To open the preferences window, please select File > Settings in the menu on Linux.
I’ll fix the documentation.
Thanks.

Found it, thanks :slight_smile:

However, ipm is not available on my system. Trying to invoke it from the command line on Ubuntu, I get:

~ me@me $ ipm
No command 'ipm' found, but there are 16 similar ones
ipm: command not found

Please follow the instructions in the documentation:

ipm is not installed automatically. The command is available in the path of <path-to-inkdrop>/resources/app/ipm/bin/ipm}.

Great, that works, thanks. My bad for not noticing that in the documentation.

Thanks a lot for all your help, and thanks for a fantastic product! Read your Medium story (assuming you’re the founder. If not, thanks to you too!), and it was both inspiring, informative, and how I discovered Inkdrop. Keep up the great work :wink:

3 Likes

Glad you enjoyed my blog post! I’ll keep posting my experiences. Hope it will be helpful. Thanks!

1 Like

On OS X I get the following error when I try to install plugins with ipm. Any ideas? Thanks!

    module.js:327
    throw err;
    ^

Error: Cannot find module './docs'
    at Function.Module._resolveFilename (module.js:325:15)
    at Function.Module._load (module.js:276:25)
    at Module.require (module.js:353:17)
    at require (internal/module.js:12:17)
    at Object.<anonymous> (/Applications/Inkdrop.app/Contents/Resources/app/ipm/lib/apm-cli.js:40:127)
    at Object.<anonymous> (/Applications/Inkdrop.app/Contents/Resources/app/ipm/lib/apm-cli.js:237:4)
    at Module._compile (module.js:409:26)
    at Object.Module._extensions..js (module.js:416:10)
    at Module.load (module.js:343:32)
    at Function.Module._load (module.js:300:12)

Sorry, it’s a bug and I’m working on it now. Please wait for a while.

Will do. Any chance you’ll release a web app version of Inkdrop? I know one could roll their own with the api (well, I’m not sure that I could do it…).

Thanks, loving this app! :heart_eyes:

This problem should be fixed in v3.14.2 that has been released just now.

The web version is not planned yet though, I understand it’d be great if we could view notes on browsers.
I’m currently working on the current roadmap here and I would like to hear what improvements people want next after finished it.

Thanks for the suggestion!

First wow: fastest bug fix ever. Works perfectly now. I’ve installed the key plugins and am off and running.

Second wow: this app is wha I’ve been searching for, it’s almost exactly how I would have designed it. As mentioned above, “Inkdrop in the browser” is the only key thing missing for me (perhaps with some sort of clipper browser plugin). This will be less of an issue if I can get it running behind the proxy server at work (already checked out the docs for this, just need to give it a try). I don’t need the teams functionality, and am glad you’re not interested in adding the overhead and clutter that it would entail.

One other thing (and I will, as you suggested, put in a feature request after the current roadmap). A ‘copy’ button in the toolbar above notes would be awesome (like code snippet managers all have).

Thanks, keep us the amazing work!!!

Great to hear that it is working!
I’m happy to know it matches your needs.
Yeah, I confirmed that it works well behind a web proxy for some people.
You can also extend the app by creating a plugin for such as adding copy feature as you mentioned (currently there’s no way to add a button to the toolbar though).

Thank you for letting me know your thoughts!
I’ll keep improving it, please enjoy it.

Sorry if I interrupt sb. by reviving this old thread. I just want to add that for Ubuntu (or maybe Linux in genera) the path to imp is /usr/lib/inkdrop/resources/app/imp. The <path-to-inkdrop> description is not very helpful, to be honest, as the result of which inkdrop is /usr/bin/inkdrop. Obviously, there is no /resources folder there. Took me some time to figure it out.

Hi Xucong,

Yeah it was unclear.
Thank you for the pull request on GitHub!

Ya I’m still having trouble understanding how to install ipm via Linux/Ubuntu. I tried cloning, installing libgnome-keyring-dev but I am confused regarding what command I’m supposed to do with this path folder in order to get to install ipm so I can finally install plugins. Please help? `

@anon89490195

For example, if you have ipm at /usr/lib/inkdrop/resources/app/ipm/bin/ipm, create a symlink for it by below command:

sudo ln -s /usr/lib/inkdrop/resources/app/ipm/bin/ipm /usr/bin/ipm

Now you can run it with just ipm.
Then, please follow this instruction to use ipm.

1 Like

Hello there!

Just installed Inkdrop on Solus Os (linux) and it works just fine. I was about to make a post about it, for any Solus OS user that could be interested in Inkdrop… but ipm doesn’t seem to work.

it tells me this:

bash: ipm : commande introuvable

wich means (if you don’t speak french) that bash can’t find ipm command line.

(of course, I tried every solution posted here before posting this comment and reviving the post haha :slight_smile: )

Hi I installed on Ubuntu via Snap and followed the documentation by navigating to /snap/bin but when I type ipm install <package_name> it is still giving me the dreaded Command 'ipm' not found :frowning:

Is there something I’m missing. I wish the documentation were a little more clear because I feel like I followed the instructions.

Please help!