Frequent crashes after updating to 5.8.0

Usage environment

  • Platform: macOS
  • Platform version: 13.6.3(22G436)
  • App Version: 5.8.0 (5.8.0)

How to reproduce

After updating to 5.8.0, it started crashing frequently. It crashes on startup. It will finally start up after a few times, but there is a high probability that it will crash again when saving and syncing notes.
I downloaded the latest version from the official website and tried overwriting itself, but the symptoms still remain.

Hi tecs,

Thanks for the report.
That’s weird. I haven’t ever had crashes in v5.8.0 so far. Have you tried restarting macOS?

Can you try enabling logging and report what kind of error you get?

Plugins may cause those crashes. Please try uninstalling third-party plugins.

I have restarted the PC. However, the symptoms remain the same.
The log was run until it crashed.

~ ❯ /Applications/ --enable-logging         ⏎
  app:info Creating app window +0ms
  app:info Initializing inkdrop app.. +84ms
  app:info Starting inkdrop app.. +1ms
  app:info axios default config: { proxy: false, httpAgent: undefined, httpsAgent: undefined } +0ms
  app:info Starting a session +12ms
[12862:0408/165917.856021:INFO:CONSOLE(1538)] "module.paths: /Users/hogehoge/Library/Application Support/inkdrop/packages/math/lib/node_modules,/Users/hogehoge/Library/Application Support/inkdrop/packages/math/node_modules,/Users/hogehoge/Library/Application Support/inkdrop/packages/node_modules,/Users/hogehoge/Library/Application Support/inkdrop/node_modules,/Applications/,/Applications/,/Applications/,/Applications/,/Users/hogehoge/Library/Application Support/node_modules,/Users/hogehoge/Library/node_modules,/Users/hogehoge/node_modules,/Users/node_modules,/node_modules", source: /Users/hogehoge/Library/Application Support/inkdrop/packages/math/lib/index.js (1538)
[12862:0408/165917.866555:INFO:CONSOLE(1)] "Could not load paste-as-markdown@2.0.0 because it uses deprecated APIs that have been removed.", source: file:///Applications/ (1)
[12862:0408/165917.866880:INFO:CONSOLE(1)] "Could not load paste-as-plain-text@2.0.0 because it uses deprecated APIs that have been removed.", source: file:///Applications/ (1)
  app:info Command line argument: /Applications/ +929ms
  app:info Arguments: /Applications/ +0ms
  app:info Command line argument: --enable-logging +0ms
  app:info Arguments: --enable-logging +0ms
[12862:0408/165917.977854:INFO:CONSOLE(2304)] "gemoji: function remarkGemoji() {
  return tree => {
    visit(tree, 'text', node => {
      const value = node.value;
      /** @type {string[]} */
      const slices = [];
      find.lastIndex = 0;
      let match = find.exec(value);
      let start = 0;
      while (match) {
        const emoji = /** @type {keyof nameToEmoji} */match[1];
        const position = match.index;
        if (, emoji)) {
          if (start !== position) {
            slices.push(value.slice(start, position));
          start = position + match[0].length;
        } else {
          find.lastIndex = position + 1;
        match = find.exec(value);
      if (slices.length > 0) {
        node.value = slices.join('');
}", source: /Users/hogehoge/Library/Application Support/inkdrop/packages/markdown-emoji/lib/index.js (2304)
[12862:0408/165917.978420:INFO:CONSOLE(1)] "'mermaid.themeCSS' could not set the default. Attempted default: undefined; Schema: {"title":"Custom theme CSS","type":"string","description":"Example: text { font-size: 30px !important; }"}", source: file:///Applications/ (1)
[12862:0408/] Error parsing certificate:
ERROR: Failed parsing extensions

[12862:0408/] Error parsing certificate:
ERROR: Failed parsing extensions

[12862:0408/] Error parsing certificate:
ERROR: Failed parsing extensions

[1]    12862 trace trap  /Applications/ --enable-logging
~ ❯                                                                                                                          ⏎

I’m currently deleting some plugins and seeing what happens.

I removed all the plugins that could be removed, but the situation did not change. It still crashes.

Thanks for the information.
I’ve looked into the log but there isn’t anything relevant to the crash, unfortunately.
You mentioned that it often crashes when saving and syncing notes.
There might be some issue in the local database, which causes an error in the native layer, like LevelDB or SQLite3.
So, can you try the following steps?

  1. Ensure you’ve taken a backup
  2. Quit Inkdrop
  3. Go to the user data directory
  4. Remove the db folder - Caution: It removes the entire local database. Alternatively, you can rename the folder to something like db.bak.
  5. Launch Inkdrop and sync data from scratch

Hope it solves!

thank you.
I followed the steps and it seems to be stable so far. It was helpful.

1 Like

Great to hear that! Thanks for letting me know.