Emoji plugin doesn't work


(kevin Mr) #1

Bug report

emoji plugin doesn’t work. I’ve already successfully installed that plugin, I can see it from file-setting-plugin

and I restart the Inkdrop and test it, it doesn’t work.

Info

  • Platform: windows
  • Platform version: 10
  • App Version: (3.25.4)

(Takuya Matsuyama) #2

Hi Kevin,

Thank you for reporting it.
That’s weird.
I would like to know following information:

  • What version of markdown-emoji have you installed? You can check it with ipm ls command.
  • Did you reload the app?
  • Are there any errors you got in Developer Tools?

Thanks!


(kevin Mr) #3

ipm
yes, I reload
no errors
image


(Takuya Matsuyama) #4

Thanks for the information.
markdown-emoji@1.0.0 is not compatible with Inkdrop v3.25.4 since it is built for v4 which is currently in beta.
Could you please try the old version like so?

ipm install markdown-emoji@0.3.1

Hope that works.


(Takuya Matsuyama) #5

I found that markdown-emoji has an invalid engine field which should be engines in its package.json. I will fix it. Thanks!


(kevin Mr) #6

Cool, that works, thanks a lot.


(Takuya Matsuyama) #7

Great!