Editing > Font Family doesn't work for Mplus fonts


(Rino) #1

Info

  • Platform: macOS
  • Platform version: Mojave 10.14.5
  • App Version: (4.0.0)

Sequence to reproduce

  1. Open Preferences. Point to Editing.
  2. Add “MigMix 1M” to Font Family. Note that MigMix 1M is mono-spaced font, included in the Mplus fonts.

Expected behavior

  • Editor text should be drawn using MigMix 1M.

Actual behavior

  • Editor is drawn by the Courier font instead of MigMix 1M even though Courier is not in the Font Family list.
  • FYI, editor text is rendered normally if other fonts (except the Mplus font) is specified.

(Takuya Matsuyama) #2

Hi Rino-san,

Thank you for reporting it.
I guess you have to enclose the font name like "MigMix 1M" since it has a whitespace.

Hope that helps!


(Rino) #3

Now editor text is rendered as expected with "MigMix 1M". Thank you very much!

Anyway, my default settings of Font Family is as follows:
SFMono-Regular,Consolas,Liberation Mono,Menlo,Courier,monospace

The font Liberation Mono also contains a whitespace in its name and it is not enclosed by quotation marks. Is it OK?


(Takuya Matsuyama) #4

Aaw thanks for pointing it out. Yeah it should be quoted as well! I will fix it.