Crash on MacBook M1 2020, macOS version 12.01

Thanks for creating this nice app! Now over to the issue:

I just installed the desktop version of inkdrop on my MacBook M1 2020, macOS version 12.01. (I have already used the app for a couple of days on Linux). I opened the desktop app, and everything looked ok, it showed all notes I created on the linux machine (so the sync was working). But when I tried to create a new note, after entering the title of the note and then clicking in the edit area to start editing, the app crashed:

Here is a complete crash report. The problem can be reproduced (have tried to reopen the app 3 times now and the same error occurs each time)

Hi Hakon,

Thank you for the report. That’s weird.
Firstly, the app version is 4.2.3 in the report but the latest version is 5.5.0. How did you install it?
I have M1 MacBook Air as well but it works fine.

Can you please try downloading the latest version from the website?

If you are on the latest version, I need to reproduce it.
Have you installed any plugins?


Ahhh, I got it.
You’ve installed the app from App Store. That’s why the version is 4.2.3.
What you’ve installed is the mobile version.

So, please install the desktop version from the website.

1 Like

Thanks! That was it. I removed the version I installed from app store, and downloaded the zip archive for Apple silicon. This works fine now :slight_smile: Have a great day.