Can't remove text in Android app

Bug report

I just downloaded the Android app and started on my first note. I can’t remove text at all. If I hold backspace it reappears when the cursor reaches the start of the line and it also reappears when I type more after deleting. Selecting the text and pressing backspace also does not work. Seems like a sync issue, but also happens when synchronization is set to “don’t sync”.


  • Platform: Android
  • Platform version: Android 9 Oxygenos 9.03
  • App Version: latest 15 Oct


Start a new note in the Android app and try to remove text.

Here is the note I tried this in:

But it also happens in other notes.

Hi Y,

Thank you for reporting it.
That’s weird, I tried to reproduce it but couldn’t.
Maybe it’s an input method-dependent issue or a device-dependent issue.

I just tried SwiftKey and the problem did not occur there, so it must be a Gboard thing.

I’m actually using Gboard on Android 10 on Essential Phone but it seems that the issue doesn’t happen.
It works fine on Android 9 as long as I test.
Gboard is always unstable though…

Thank you for your response.

I have to correct myself: it’s not true that nothing gets deleted, only the right-most character gets removed and all other characters reappear. So eventually, you could remove all text if you just held backspace long enough.

It happens when the cursor reaches the start of the line and backspace is pressed again, or when new text is typed. It does not happen unless the right-most character is removed. This only happens with Latin alphabet Gboards (not Japanese or Korean).

There’s also some other weirdness going on using Latin Gboard: text can sometimes not be selected and the cursor sometimes moves one place left/right while typing or holding backspace.

The one Gboard setting that appears to trigger this is “Show suggestion strip (Display suggestion strip while typing)”, found under “Text correction”. Setting that to off fixes the main issue (although some others remain) and setting it back on triggers the behavior again.

Thank you for the further investigation.
I managed to reproduce it.
That’s exactly due to Gboard’s inconsistent behavior (as always).
As you found, the most issues on Gboard don’t happen when disabled suggestion.
Gboard’s word suggestion involves text composition whose events are inconsistently fired.
That’s the main cause of the bugs.
I’ll work on it tomorrow.
Thanks again!

1 Like


I published a fixed version (build number: 44) on beta channel.
Could you try it? You can download it from here:

It should work without the issue you reported.
But Gboard’s text correction/suggestion basically works inconsistently and unexpectedly, and that’s hard to handle perfectly in terms of implementation based on webview.
Holding backspace would sometimes still cause unexpected behaviors since the timing of events Gboard fires is not consistent.

Got checked by another user that it works fine.
v3.3.0 is out.
Thanks again for reporting.

1 Like