Can't publish a plugin

Bug report

I’ve just updated my plugin switch-notebook, I’m trying to push a new minor version but I’m unable to login:

$ ipm publish minor                                                                                                                                               
(node:15031) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.
(Use `node --trace-deprecation ...` to show where the warning was created)
Preparing and tagging a new version ✓
Pushing v0.2.0 tag Username for '': marconi
Password for '':
remote: Invalid username or password.
fatal: Authentication failed for ''


  1. First off I cloned this using ssh, why is it asking for my username and password?
  2. Also even with the right credentials it still fails, how do I configure ipm to push using ssh?


  • Platform: (macOS)
  • Platform version: (Catalina/10.15.2)
  • App Version: (5.3.1)

Hi Marconi,

Thank you for the report.
ipm looks the package.json.
So, you have to update the "repository" value in package.json to use SSH like so:

  "repository": {
    "type": "git",
    "url": "git+"
1 Like

Thanks, that didn’t work but now that I know where to update this worked for me:

  "repository": {
    "type": "git",
    "url": ""

Cheers, thanks!

@craftzdog Quick question though, I can install my plugin via the app but it doesn’t show-up on It has 479 downloads so should be relatively popular. :laughing:

1 Like

Oops, sorry. Glad it worked!
I just fixed the issue where the search is not working.

Congrats on nearly hitting 500 downloads! I really appreciate your work.
Have a nice day.