Can't install Inkdrop in some Debian based distro's

Hi, first of all I like Inkdrop very much. I have searched for years for a good markdown based note taking app which could use subfolders so I can structure my own notes.

I use Inkdrop on iOS, Android, Windows, Mac and Linux. In Ubuntu or Linux Mint installing of inkdrop is no problem, but when I use Debian based distro’s like Kali Linux or Parrot OS I can’t install Inkdrop…

Bug report

When installing Inkdrop with:

sudo dpkg -i inkdrop_3.22.2_amd64.deb

I get these messages:

Preparing to unpack inkdrop_3.22.2_amd64.deb ...
Unpacking inkdrop (3.22.2-1) ...
dpkg: dependency problems prevent configuration of inkdrop:
 inkdrop depends on libgconf2-4; however:
  Package libgconf2-4 is not installed.

dpkg: error processing package inkdrop (--install):
 dependency problems - leaving unconfigured
Processing triggers for bamfdaemon (0.5.3-3) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils (0.23-3) ...
Processing triggers for mime-support (3.61) ...
Errors were encountered while processing:

It looks like the problem here is that libgconf2-4 is not installed, So I tried this:

sudo apt install libgconf2-4

This returns:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libgconf2-4 : Depends: libgconf-2-4 (= 3.2.6-4.1) but 3.2.6-5 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

So I tried the offered solution in this message:

udo apt --fix-broken install

This leads to this message:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 268 MB disk space will be freed.
Do you want to continue? [Y/n]

Choosing Y leads to uninstalling Inkdrop :frowning:

Choosing n leads to problems every time you try sudo apt upgrade because of the Inkdrop install being broken :frowning:

Do you know a solution for this?

(I also read you are working on a snap package. Can we expect this soon, because maybe this would be a solution for this problem)


  • Platform: (Kali Linux, Parrot OS)
  • Platform version: (Kali 2018.3a, Parrot 4.2.2)
  • App Version: (3.22.2)
1 Like

Looks like Inkdrop or a package in the inkdrop install requires version 2.4 of libgconf, while your system (or a package on it) requires version 3.2.6 to 4.1.

For a direct fix, I’d say use the web version of Inkdrop. This is an issue with a package dependency in Inkdrop (probably Electron even), and can’t really be fixed easily.

However, a quick web search shows it is possible to install multiple versions of a library. It would require manually downloading said library, placing it in another directory, and extending a path variable with your custom library directory. Read more here.

I will try your possible solution when I’m at my computer again.

I was nog aware that’s there was a web version of inkdrop? Where can I find this?

And thnx for your quick answer!!

Hi @Mike_Blackstone,

Web version is not available, and not planned.

As @ZeroThe2nd pointed out, libgconf2-4 is a dependency for Electron and hard to change.
The package is basically built for the recent version of Ubuntu and Debian.
If you are on other distro and can’t install it, you can try a zip file (not .deb file) which can be used without apt installation.
If it didn’t work, you have to solve problems by yourself.

1 Like

Ah, thank you. I Will try that!

Edit: ZIP option worked like a charm :slight_smile:

problem solved

1 Like


1 Like

I apologise for the confusion with the web version. I had never logged into the portal, and kinda assumed it was a web version.
I’m sorry :slightly_frowning_face: