Can't do a fresh reinstallation after certificate expiration error

Bug report


  • Platform: macOS
  • Platform version: 11.6
  • App Version: LATEST

How to reproduce

I can’t do a fresh install of inkdrop. I had it installed earlier. Came back, saw a certification expiration error. Tried to download the fresh app from: - zip archive(x64) but the app keeps crashing on startup without any conspicuous error which I can share. There is a split-second change in the top app bar, where it goes from “Finder” to “Inkdrop” and then Inkdrop crashes and it again reverts back to finder. I have no logs to share here.

I may have installed some plugin regarding Markdown Table of contents. But this app is not starting, I can’t confirm anything.

Hi Ashish,

Thank you for the report. That’s weird.
If you are on an M1 mac, please use the Arm64(Apple silicon) build instead of the x64(Intel) build.

Can you please try running it from Terminal with the following command:


And let me know what you get.

I am on normal Mac(not M1).

This is weird. The directory is not present in the Applications folder.

-bash: /Applications/ No such file or directory

Does it tell you anything?

That means that the application is corrupt.
Can you please try downloading the file again?

So I’ve made some progress in an even weirder way. There was an “Inkdrop 4” app in my ~/Downloads… To avoid confusion, I tried to delete it but I couldn’t. The error said it’s already open. But I had my Mac restarted recently so that couldn’t have been the case.

I simply renamed it to something else and then deleted the stray “Inkdrop 4-renamed” app and the download app is now working and DB is being migrated.

Hmm, that’s so weird but good to hear that it’s been resolved.