Cannot Log In on Windows Newly Installed App

Bug report

**Description: **
I just installed the Windows app and when I launched it I get this error

The login window is still there, but I try to log in I get this:


  • Platform: Windows
  • Platform version: Windows 11 Pro 22H2
  • App Version: 5.6.2

How to reproduce

  1. Download the latest app version for Windows
  2. Launch the app
  3. Log in

Hi Mikoo,

Thanks for the report.
That’s weird.
The error happens when it fails to get credentials from Credential Vault.
Have you ever used Inkdrop before?
Do you have sufficient permission to store credentials on your computer?

No, I haven’t. This is my first time installing and using the app. I have sufficient permissions as I am using my personal computer. I have also tried running the app as administrator and the issue still persists.

I tried to log out and log in again on my Windows 11 Pro machine (22H2) but couldn’t reproduce it.
I’m afraid I can’t help you at the moment but please let me know if you find anything related to this issue.

I suspect that the issue is caused by keytar, which is quite old now.
I’ll plan to replace it with Electron’s safeStorage in the near future: