Cannot copy and paste image from clipboard

Bug report

Whenever I try to copy and paste image from clipboard nothing happens on editor.
Pasting text works just fine but not image. Only drag and drop or attaching works.
Is pasting image from clipboard not supported?


  • Platform: macOS
  • Platform version: Ventura/13/2/1
  • App Version: 5.5.3

How to reproduce

It’s simple. Just take a screenshot and copy to clipboard, then paste it in Inkdrop editor.
But I’m afraid this happens only on my Inkdrop app :frowning:

Hi Sonia,

Thanks for the report. That’s weird.
I can’t reproduce it in my environment.
I took a screenshot and it has been successfully pasted into the editor by pressing Cmd-V.
Do you get any errors in the developer console?
How large is your screenshot in MB?

1 Like

Hi Takyua,
Thanks for the reply.

I find it weird also, and I also expected it would be difficult to reproduce.
The size is not large at all. KB size images cannot be pasted as well.
Is there any way to reset all the Inkdrop configurations other than deleting the directory from below path?

MacOS: /Users/username/Library/Application Support/inkdrop

I just want to try restoring default settings and try again.


I guess resetting the configuration does not solve it.
Are you able to insert an image file by D&D from Finder?
Have you installed third-party plugins?
Do you get no errors in the developer console?

1 Like

D&D works perfectly fine from both Finder and anywhere as well.

I did add some theme plugins as well as the list of below third-party plugins.

This is what I get from the developer console when I toggle it.
But there is no additional error when I try to paste images in.

Thanks for the information.
paste-url is a community-made plugin that could affect the default behavior.
Can you disable it?

1 Like

Well, still doesn’t work… :frowning:
Anything else I can try?

Have you restarted the app?

If it’s still not working, do you use any clipboard manager tool or anything like that?
If not, we have to look into the clipboard data.
What do you get if you run the following code in the developer console, after copying a screenshot?
Note that your clipboard replaces the data when you copy the below code. Be sure that the clipboard has the screenshot data when running the code.

var clipboard = require('electron').clipboard

The expected output is:

Screenshot 2023-02-27 at 13.32.34

1 Like

You are totally right, Takuya!!
This is what I get on developer tool.

I am using CleanShotX and when I copy an image using CleanShotX shortcut keys, I cannot paste images in Inkdrop.

But when I use default MacBook shortcut keys to copy an image to clipboard, it is pasted in Inkdrop.

This means, I need to use different shortcut keys when I want to paste images in Inkdrop, right?

Yeah, looks like CleanShot X is the culprit.
But I’m kind of confused why the clipboard has text/uri-list instead of image/png. That looks not normal.
Can you check the CleanShot X settings? I guess there should be a setting that changes how it stores screenshots in the clipboard.
Inkdrop looks into clipboard data, so it can’t paste into the editor unless you have correct image data in it.

1 Like

Cool, there was an option to decide which format I would copy to clipboard.
Default setting was both File and Image.
When I changed to Image only, copy & paste worked totally fine in Inkdrop!!!

Thanks so much Takuya!!

1 Like

Cool! Thanks for letting me know.

1 Like