Cannot access API key page


(Paul White) #1

Hi I am having a problem accessing the API Key page. When I access it, it loads, the disappears. Very strange!
I am using Firefox 60.3.0esr (64-bit) on Debian Stretch, Linux 4.9.0.

To better explain the problem, I recorded what happens https://cloud.vascowhite.co.uk/s/DYCeBTF96tj2faT

Any idea what is going on?

Cheers


(Takuya Matsuyama) #2

Hi Paul,

Thank you for reporting.
That’s weird. I checked it works correctly on Firefox, macOS.
I couldn’t open your link (connection failed) so could you check it?


(Paul White) #3

Sorry, the link should work now.


(Takuya Matsuyama) #4

Thanks. I viewed your video. Yeah, that’s so strange. Seems like the entire web app or React itself crashed.
I would like to know:

  1. Is there any error in console?
  2. Does it only occur at API keys page?

(Paul White) #5

Hi Takuya,

Output from the console:-

[bugsnag] Loaded! app.js:57:261468

The resource at “https://api.mixpanel.com/decide/?verbose=1&version=1&lib=web&token=058c4ca480354f1f0821217c79e7f0a7&ip=1&_=1543570017357” was blocked because tracking protection is enabled.[Learn More] api-keys

Content Security Policy: The page’s settings blocked the loading of a resource at self (“script-src”). Source: ;!function(){var t,e,n,o=0,u=function(t,… controller-cdfa7859b4d3c7a31260f862393869cc.html:1

Invariant Violation: Minified React error #185; visit https://reactjs.org/docs/error-decoder.html?invariant=185 for the full message or use the non-minified dev environment for full errors and additional helpful warnings. Stack trace: o/<@https://app.inkdrop.info/app.js:113:424 o@https://app.inkdrop.info/app.js:113:199 ja@https://app.inkdrop.info/app.js:113:77553 enqueueSetState@https://app.inkdrop.info/app.js:113:46457 g.prototype.setState@https://app.inkdrop.info/app.js:65:1578 b/</o</o.prototype.onStateChange@https://app.inkdrop.info/app.js:1:60545 notify@https://app.inkdrop.info/app.js:1:56335 m</e.prototype.notifyNestedSubs@https://app.inkdrop.info/app.js:1:55940 b/</o</o.prototype.onStateChange@https://app.inkdrop.info/app.js:1:60563 notify@https://app.inkdrop.info/app.js:1:56335 m</e.prototype.notifyNestedSubs@https://app.inkdrop.info/app.js:1:55940 b/</o</o.prototype.onStateChange@https://app.inkdrop.info/app.js:1:60563 _@https://app.inkdrop.info/app.js:1:109185 o/</</<@https://app.inkdrop.info/app.js:132:228214 L/</</<@https://app.inkdrop.info/app.js:1:94895 c/<@https://app.inkdrop.info/app.js:1:111340 value@https://app.inkdrop.info/app.js:57:214713 value@https://app.inkdrop.info/app.js:57:215616 value@https://app.inkdrop.info/app.js:57:216940 Li@https://app.inkdrop.info/app.js:113:47043 $i@https://app.inkdrop.info/app.js:113:56579 Qi@https://app.inkdrop.info/app.js:113:60303 Sa@https://app.inkdrop.info/app.js:113:74339 Ya@https://app.inkdrop.info/app.js:113:74685 co@https://app.inkdrop.info/app.js:113:79353 uo@https://app.inkdrop.info/app.js:113:79007 ho@https://app.inkdrop.info/app.js:113:85014 He@https://app.inkdrop.info/app.js:113:10326 Sn@https://app.inkdrop.info/app.js:113:30717

app.js:57:266772

This only happens on the api keys page. All other pages are OK.
I tried disabling tracking prevention for inkdrop.info, but that had no effect.


(Takuya Matsuyama) #6

Thank you, Paul.
I’ll try to reproduce it!


(Paul White) #7

Could it be a clash with a plugin?

I have the following installed and enabled:-

Just a thought.


(Takuya Matsuyama) #8

Possibly. To clarify, could you try it on other browsers?


(Paul White) #9

I tried it in Chrome Version 70.0.3538.110 (Official Build) (64-bit) with the same result. No extensions, and clean install as I don’t use it.


(Takuya Matsuyama) #10

Thank you for the information.
I’m struggling to reproduce it.
I checked your account but it seems no problem.
Just in case, I updated React version so perhaps it might fix the problem.
I’ll deploy a dev build to another domain so that we can see the React error report.
Please wait for a while.
Sorry for the inconvenience!


(Takuya Matsuyama) #11

I tried to reproduce it on Debian but couldn’t:

  • Debian 9 (stretch)
  • Linux 4.9.0-8-amd64
  • Firefox 60.3.0esr

As we talked through email, the problem also occurs with the demo account. So your account doesn’t cause it.
I guess it’s your environment problem and please try it on other machine.