Android Sync Appears Broken


(Joshua Douty) #1

I’m having issues with notes originating on my Android device getting synced and seeing them on the Mac App. This is a brand new install on both my Mac and my Android phone and I’m trying to app out for the first time.

I was testing out some of the features of the Android app and tried to create a note with an image attached. This seems to screw with syncing because nothing would sync after this note was created. I could create additional notes and they would never show up on the Mac app.

Ended up deleting that note and syncing worked again. So, I tried creating a note with an image again. This time it appears in the Mac app but the image just shows a broken image link.

I was able to create a note from the Mac app that had an image and I was able to successful view that image from the Android app. But that seemed to break syncing again from the Android app.

I’ve also had some Android app crashes when backing out of an edited note that caused those changes to be lost.

Bug report

Write the description of the issue here.
If you got a problem, please check if you got any error in the console log by selecting the menu: Developer -> Toggle Developer Tools.

No errors in the console on the Mac app.

Info

  • Platform: Pixel 3 - Android 9 / Macbook Pro 2017 - Mojave 10.14.5
  • Platform version: (Mojave/10/16.04)
  • App Version: Android 3.0.0 (Updated May 23, 2019) / Mac 4.0.1

Reproduce

  1. Create a note with an image on Android

(Takuya Matsuyama) #2

Hi Joshua,

Thank you for reporting it.
That’s weird.
I tried to reproduce it but I could successfully add an image on Android and get synced across devices.

I also confirmed that your images are stored on the server.

the Mac app but the image just shows a broken image link

Is this image still not shown on your mac? Please try waiting for a while until the image has been synced and reloading the note when you inserted an image.


(Joshua Douty) #3

I can try reinstalling the Android app. Maybe something got a little weird?

But, I just checked the Mac app and didn’t see the latest images I had added to my test note but everything was saying synced. I had to update the name of the note to get it to resync on my Android and then I could see new broken links in the Mac app for the new images I added.

Does it sync in the background? It wasn’t showing syncing on my Android app and just had the date and time so I took that as being fully synced.

I will say, 1 of my 4 images in that test note is showing up on the Mac app but the other’s still aren’t.

Thanks for your help! Hopefully we can track down what’s causing the weirdness.


(Takuya Matsuyama) #4

The android app basically syncs while it’s on foreground.
I confirmed the server logs regarding that you inserted one image and getting synced.


(Joshua Douty) #5

Okay, so I reinstalled both the android app and the mac app but things are weirder than even.

Everything looks fine on my Android app so no change there. But all the notes are now gone in the Mac app. Even though I’ve selected synchronize notes on the Mac app and the Android app. I had to edit the notes individually on the android app for them to be resynced and showing up in the Mac app again.


(Takuya Matsuyama) #6

Sorry for the trouble.
However I don’t see errors in the server log. Seems like syncing working.
I guess the issue happens on the client.
You can launch the mac app from terminal like so:

/Applications/Inkdrop.app/Contents/MacOS/Inkdrop

If there is an error happened, you will see error logs.


(Joshua Douty) #7

Just gave that a try and I’m seeing some 404 errors on the image loads.

  app:error Failed to load image: { [not_found: missing]
  status: 404,
  name: 'not_found',
  message: 'missing',
  error: true,
  reason: 'missing',
  docId: 'file:jKt5rd51m' } +0ms

I’ll give it another go tomorrow! Thanks!


(Takuya Matsuyama) #8

Thanks for the information.
So it appears that the mac app is not fully synced for some reason.
I can see file:jKt5rd51m is stored in the server.
Inkdrop stores your data in local here:

~/Library/Application Support/inkdrop/db

To let it perform a full sync from scratch:

  1. Quit the app
  2. Move db folder to somewhere
  3. Start the app from terminal again
  4. See what’s going wrong

Thank you for your cooperation!


(Joshua Douty) #9

Just tried that. This is the only output from the terminal until I open the note with the missing images which gives me the 404 again.

[bugsnag] Loaded!

2019-06-10 06:37:15.608 Inkdrop[36973:2766067] *** WARNING: Textured window <AtomNSWindow: 0x7fa81165cdf0> is getting an implicitly transparent titlebar. This will break when linking against newer SDKs. Use NSWindow's -titlebarAppearsTransparent=YES instead.

(Takuya Matsuyama) #10

Hi,

I had a similar issue on other user and got resolved.
Could you try this patch?

https://inkdrop-dist.s3-ap-northeast-1.amazonaws.com/tmp/Inkdrop-4.0.1-Mac-patch-3.zip


(Joshua Douty) #11

Nice! I had to clear the db but that seems to have fixed the issues I was seeing.

Thanks for all the help!

Now I just wish I wasn’t using Centos 7 on my work computer so I could have access to inkdrop there as well!


(Takuya Matsuyama) #12

Great! Thank you for checking it out.
I’ll roll it out!

Yeah unfortunately CentOS is not officially supported. It is so hard to make it support every distribution :sweat_smile:


(Takuya Matsuyama) #13

v4.0.2 is out. Thanks again for reporting!