Adding a relatively small image has broken sync

Bug report

I locally inserted (drag-and-drop) a relatively small image into a note and Ubuntu Desktop version is constantly syncing now, but can’t manage it. I deleted link to an image, but it still is trying to sync.

Info

  • Platform: Ubuntu
  • Platform version: 16.04
  • App Version: Latest stable

Reproduce

Insert this image and see if sync is ok.

Hi, thank you for reporting.

I’ll check it and get back to you soon.

I tried to reproduce this problem but it successfully synced.
Currently, the image won’t be deleted from the server if you delete the image statement ( ![image.png](inkdrop://) ).

Is the app still getting stuck syncing?
Please tell me if you’ve got any error output on the developer console.

Do you have sufficient disk space?

@craftzdog, thanks for your prompt support. Yes, I have more than free disk space available (45G free). Unfortunately, it’s still stuck to “syncing” and I really don’t know what to do as I even have deleted this note with image and even entire notebook but no result, the sync is still broken.

No errors as I understand, just this info message:

/usr/lib/inkdrop/resources/app.asar/node_modules/react/lib/ReactDOM.js:66 Download the React DevTools for a better development experience: https://fb.me/react-devtools

OK, I’ll look into your account.

Thanks, @craftzdog!

Also it seems like Inkdrop went crazy with my account as I just tried to try “Restore…” option but it didn’t produce any effect at all (deleted items aren’t restored from local backup).

I confirmed your HTTP requests have been terminated in the middle of the request.
So the server ends up failing to receive entire data.
It seems that this problem is caused by the client side.
Do you have any network restriction in mind?
Your requests over 1MB via HTTPS are interrupted.

Sorry, it’s midnight here in Japan.
I’ll get back to you tomorrow.
Please stop your Inkdrop process until then.

Thanks

Maybe your sync works now?

The local backup works in real-time. When you deleted a note from the app, it immediately reflects to the disk. So deleted notes won’t be restored.

good night…

@craftzdog yes, now it works! What was the solution? Was it serverside problem in the end?

Yes, sorry for the trouble.
Your attachment image above is over 1MB and the server (nginx) refused it by my misconfiguration.
I couldn’t notice that in my local dev environment.

Thank you so much for your report!

No problem! Have a nice night. See you!

1 Like